I haven't tried pk2 on a PIC16F mcu yet. I have talked to Microchip technical support about my problem, and they suggested that it could be b/c of pk2 not sending the fusebit controls properly. Jan is ordering some 2620 and working on it to see whether the same problem is replicated on his side. Just wanted to give the readers an update of what's going on now.

Stanley

On 10/18/07, soliton <soliton.list@gmail.com> wrote:
It seemed the same problem happened to me with PIC16F88, my
application could not run without using the USB port power supply. But
I didn't change anything and it work again, very strange. Just an
idea, have you tried it using 3 pieces of battery as power supply? And
bring your test circuit far away from the computer and any other
electrical devices. :D

On 10/14/07, Stanley Lee <stanigator@gmail.com> wrote:
> Apparently this isn't the last email on this topic. I'm not sure why this
> problem doesn't occur to 2220 but to 2620, as I need to use 2620 or its
> family chips for the purpose of my project. I've checked the pin 10 (clkout)
> with the oscillator fusebit set to output a clock on pin 10 as shown in the
> project included in the zip file. Apparently, the problem seems to be that
> the reset isn't configured properly even though it looks like it does in the
> code. I had been suggested before on the microchip forums to look into using
> BOR and PWRT. I have also tried to use an external power-up reset circuit
> for slow startups, although that never seemed to work. I'm getting lost on
> how to solve this reset issue. Any insights on this would be much
> appreciated.

--
soliton
------------------------------------
Diskusi di http://phimega.com/forums

-------------------------------------------------------------------------
This SF.net email is sponsored by: Splunk Inc.
Still grepping through log files to find problems?  Stop.
Now Search log events and configuration files using AJAX and a browser.
Download your FREE copy of Splunk now >> http://get.splunk.com/
_______________________________________________
Sdcc-user mailing list
Sdcc-user@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/sdcc-user