"/usr/bin/aslink" -nf return...

Help
wis3m0nkey
2011-05-24
2013-03-12
  • wis3m0nkey

    wis3m0nkey - 2011-05-24

    I don't see any understandable message about this particular error.
    Can any one explain it a bit for me?

    Thank you

     
  • Maarten Brock

    Maarten Brock - 2011-05-25

    I'm afraid you'll have to repeat the error message in the body as the subject is truncated by the forum.

     
  • wis3m0nkey

    wis3m0nkey - 2011-05-25

    Sorry about that,
    Here is exact message

    + "/usr/bin/aslink" -nf "test.lnk" returned errorcode 3584
    

    my c file is test.c hence test.lnk

     
  • wis3m0nkey

    wis3m0nkey - 2011-05-27

    I'm using MCU 8051 IDE which supports SDCC but I guess it is trying to compile only one file and not complete project.
    Does anyone have how to compile complete project or can someone provide me SDCC documentation for multiple .c and .h files in same project and only one main?

    Thanks

     
  • Maarten Brock

    Maarten Brock - 2011-05-28

    See 3.1.3 in the SDCC manual.

     
  • wis3m0nkey

    wis3m0nkey - 2011-05-31

    Thats the section I read and realized I need to compile include files first followed by main function.
    But next issue is what is to be done with .h files I tried compiling them same as .c files but they failed :(

     
  • Maarten Brock

    Maarten Brock - 2011-06-01

    You cannot compile include files. They are included when compiling the .c files.

    Maybe you need a good book about the C language first.

     
  • wis3m0nkey

    wis3m0nkey - 2011-06-01

    Exactly thats what I tried to do when it gave me linking error, so I thought sdcc needs to create intermediate files first.
    I'll look in to it and let you know

     

Log in to post a comment.