#1378 inited global pointer variables

closed-duplicate
5
2013-05-25
2007-10-01
Anonymous
No

This little example does not work:
typedef struct Bar_
{
int i;
} Bar;

Bar bar = {5};
Bar* bp = &bar;
void* vp = &bar;

The command line:
sdcc -c -mpic16 -p18f8680 --opt-code-size main.c -o main.o

The output:
at 79: error 129: pointer types incompatible
at 80: error 129: pointer types incompatible

Discussion

  • Maarten Brock

    Maarten Brock - 2009-11-01

    This artifact has been marked as a duplicate of artifact 1723280 with reason:
    it only uses foo instead of bar

     
  • Maarten Brock

    Maarten Brock - 2009-11-01
    • status: open --> closed
     
  • Maarten Brock

    Maarten Brock - 2009-11-01
    • labels: 101552 --> pic16 target
    • milestone: --> known_bugs
    • assigned_to: nobody --> maartenbrock
    • status: closed --> closed-duplicate
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks