#6631 DRASCULA: Music doesn't play from original directory structure

Drascula
closed-fixed
no music (1)
5
2014-06-15
2014-06-10
And Wan
No

No music, no piano tunes, nothing. Just voice.

Discussion

  • digitall

    digitall - 2014-06-10
     
  • digitall

    digitall - 2014-06-10

    andwan0:

    Firstly, please can you indicate what version of the ScummVM IOS port you are using? This is listed above the logo on the launcher screen.

    If this is v1.6.0 or earlier, then please download and install the latest daily build from here and retest please:
    http://buildbot.scummvm.org/builds.html

    Secondly, please can you attach a savegame at a specific place where this occurs to allow easy replication and investigation by the developers?

    It is worth comparing this to running in a Win32/OSX/Linux desktop build at the same point to be sure you are not confused about whether music is present.

    Thirdly, what IOS device are you using? Please include OS version.

    Fourthly, it would be useful for you to attach a text file to this bug listing your Drascula datafiles and the associated file MD5sums so we can eliminate corrupted, damaged or variant datafiles as a cause for this. The output of a tool such as http://md5summer.org/ would be optimal.

    At least, indicate which of the Drascula language variants you are using from the download page and redownload and compare to ensure that these are not modified.. This includes copying back from your IOS device as FTP can cause naming issues and other file truncations.

    Without answers to these points, investigating this problem could be a long and painful process.. please help us here by providing this.

     
  • digitall

    digitall - 2014-06-10
    • summary: iPad/iPhone port: Music doesn't play --> DRASCULA / IOS: Music doesn't play
     
  • And Wan

    And Wan - 2014-06-11

    iOS 5.1.1 (coz it's jailbroken iPad).
    my current buildbot is 1.7.0git7563-gdc4b9b8

    no need for saved game coz it's just at the start of the game.
    maybe coz iPad/iPhone SCUMM doesn't support mp3 music files?

    I tested it on ScummVM windows latest version and can hear music.

     
    Last edit: And Wan 2014-06-11
  • digitall

    digitall - 2014-06-14
    • summary: DRASCULA / IOS: Music doesn't play --> DRASCULA: Music doesn't play from original directory structure
     
  • digitall

    digitall - 2014-06-14

    I checked your MD5 values against my datafiles and was able to construct the same datafile structure.

    Music also failed to play here on Linux x86_64 with latest git master, so this is not an IOS specific bug.

    Checking with v1.6.0 showed the same problem.

    After a little debug checking, I realised that the DRASCULA engine was not picking up the MP3 files from the audio subdirectory.

    andwan0: I would suggest that when you tested this on Windows latest version, you had all the datafiles in the same subdirectory, rather than using an audio subdirectory?

    Anyway, a workaround for now is to copy all the audio files into the same directory as the rest of the datafiles i.e. Packet.001.

    I will look at fixing the engine code to search for audio files in the audio subdirectory i.e. original directory structure in future.

     
  • digitall

    digitall - 2014-06-14
    • status: open --> open-accepted
     
  • digitall

    digitall - 2014-06-14

    Ah... I see. These audio files were originally AudioCD tracks for the original game and thus are supported via AudioCD emulation.

    This only supports having the files named as track01.{mp3,ogg,flac}, track02... etc. in the root of the game data directory.

    See:
    https://github.com/scummvm/scummvm/blob/master/backends/audiocd/default/default-audiocd.cpp#L56

    andwan0: Please try moving the track*mp3 files to the same directory as Packet.001 and confirm if this then works fine on both Windows and IOS please?

     
  • digitall

    digitall - 2014-06-14
    • status: open-accepted --> open-works-for-me
     
  • Filippos Karapetis

    • status: open-works-for-me --> closed-fixed
    • assigned_to: Filippos Karapetis
     
  • Filippos Karapetis

    Fixed with commit 9c4d086165. The music add-on pack we provide contains the audio tracks in an "audio" folder, without clear indication that they should be copied in the same folder as packet.001. Thus, this case has been added, and music should play correctly in both cases (audio tracks in the same folder as packet.001, or in an "audio" subfolder)