#3487 PUTTMOON 3DO: Play button in Outtro partly cut off

closed-fixed
kirben
Graphics (902)
5
2009-01-11
2007-12-08
No

ScummVM 0.11.0svn (Dec 8 2007 08:51:43)
Features compiled in: Vorbis FLAC MP3 zLib MPEG2

In the outtro the Play (again) button is too far to
the right cutting part of it off.
Screenshot attached
SaveGame attached

PuttPutt Goes to the Moon (3DO/English)

AmigaOS4
gcc version 4.0.2 (AmigaOS build 20051012)

Discussion

  • Hubert Maier

    Hubert Maier - 2007-12-08

    Logged In: YES
    user_id=1944098
    Originator: YES

    File Added: puttmoon.s05

     
  • Hubert Maier

    Hubert Maier - 2007-12-08

    Just use the key

     
  • kirben

    kirben - 2007-12-08
    • summary: PUTTMOON: Play button in Outtro partly cut off --> PUTTMOON 3DO: Play button in Outtro partly cut off
     
  • Max Horn

    Max Horn - 2008-02-04
    • assigned_to: nobody --> kirben
     
  • Max Horn

    Max Horn - 2008-02-04

    Logged In: YES
    user_id=12935
    Originator: NO

    Travis, anything you can say about this? Can you reproduce this, or is it yet another Amiga specific problem?

     
  • kirben

    kirben - 2008-02-05

    Logged In: YES
    user_id=34715
    Originator: NO

    No, as the problem doesn't occur under DOS/Windows versions of the game, when using the Windows port of ScummVM.

    Assigning to sev, who should be able to confirm if this problem is specific to 3DO version of game, or to the Amiga port of ScummVM.

     
  • kirben

    kirben - 2008-02-05
    • assigned_to: kirben --> sev
     
  • Max Horn

    Max Horn - 2008-12-04

    What is the status of this item?

     
  • Hubert Maier

    Hubert Maier - 2008-12-04

    ScummVM 0.13.0svn (Dec 4 2008 16:00:19)
    Features compiled in: Vorbis FLAC MP3 zLib MPEG2

    Still there i'm afraid

     
  • Eugene Sandulenko

    • assigned_to: sev --> kirben
     
  • Eugene Sandulenko

    I can confirm the issue on FreeBSD.

    The relevant script attached. It puts the object at coordinates 37*8, 0, which is 296. Perhaps there are differences in drawObjectAt? As the moon and start button also seem to be off.

    [0100] (62) drawObjectAt(773,3,0)
    [010A] (62) drawObjectAt(774,37,0)

    File Added: room-38-206.dmp.txt

     
  • Eugene Sandulenko

    • assigned_to: kirben --> sev
     
  • Eugene Sandulenko

    I can confirm the issue on FreeBSD.

    The relevant script attached. It puts the object at coordinates 37*8, 0, which is 296. Perhaps there are differences in drawObjectAt? As the moon and start button also seem to be off.

    [0100] (62) drawObjectAt(773,3,0)
    [010A] (62) drawObjectAt(774,37,0)

    File Added: room-38-206.dmp.txt

     
  • Eugene Sandulenko

    • assigned_to: sev --> kirben
     
  • kirben

    kirben - 2009-01-09

    The x and y position isn't set for objects 773 and 774 in room-38-206 of the DOS version:
    [0111] (61) drawObject(773,0)
    [0118] (61) drawObject(774,0)

    I added a patch, which should work around the problem, by simply ignoring the exact x and y positions set for these objects.
    File Added: patch.diff

     
  • kirben

    kirben - 2009-01-09

    Patch for work around

     
  • Eugene Sandulenko

    • status: open --> closed-fixed
     
  • Eugene Sandulenko

    Yes, it is obviously a bug in the original scripts. I applied the patch as is.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks