#19 can't find glade.h (but it's there)

closed
None
5
2003-05-01
2002-08-29
Anonymous
No

Howdy,

I'm trying to compile screem 0.4.1 on Slackware 8.1.
./configure goes ok, but then make returns an error
that it can't find glade/glade.h. It's there in
/usr/include/libglade-1.0/glade/glade.h. And, as far as
I can tell from looking through the Makefile, that's
where it should be looking. (glade is latest version
0.6.4).

--dvd

Discussion

  • David A Knight

    David A Knight - 2002-08-30

    Logged In: YES
    user_id=736

    it's probably a problem with screem that has only shown
    itself since libglade moved version 1.0 files to
    /usr/include/libglade-1.0/ rather than /usr/include

    try CFLAGS="$CFLAGS `libglade-config --cflags`" ./configure

     
  • David A Knight

    David A Knight - 2002-08-30
    • assigned_to: nobody --> davek
     
  • Jonathan Linowes

    Logged In: YES
    user_id=686939

    me too!
    I'm using Redhat 8.0. I have glade.h in
    /usr/include/libglade-1.0/glade/glade.h and in
    /usr/include/libglade-2.0/glade/glade.h
    I tried the followup suggestion, on the command line I entered:
    CFLAGS="$CFLAGS `libglade-config --cflags`"
    ./configure
    make
    but still main.c doesn't compile. (is that what the
    suggestion said?)
    I notice that the Makefile does include a line
    LIBGLADE_CFLAGS = -I/usr/include/gnome-xml
    -I/usr/include/libglade-1.0

    so it should find it, no?

     
  • Jonathan Linowes

    Logged In: YES
    user_id=686939

    me too!
    I'm using Redhat 8.0. I have glade.h in
    /usr/include/libglade-1.0/glade/glade.h and in
    /usr/include/libglade-2.0/glade/glade.h
    I tried the followup suggestion, on the command line I entered:
    CFLAGS="$CFLAGS `libglade-config --cflags`"
    ./configure
    make
    but still main.c doesn't compile. (is that what the
    suggestion said?)
    I notice that the Makefile does include a line
    LIBGLADE_CFLAGS = -I/usr/include/gnome-xml
    -I/usr/include/libglade-1.0

    so it should find it, no?

     
  • Michael Hutchins

    Logged In: YES
    user_id=696615

    I am having this problem as well. Wish I could post a
    solution but...
    Red Hat 8.0

     
  • David A Knight

    David A Knight - 2003-02-13

    Logged In: YES
    user_id=736

    the latest stable version of screem, 0.6.0 should no longer
    have these problems.

     
  • David A Knight

    David A Knight - 2003-05-01
    • status: open --> closed
     
  • David A Knight

    David A Knight - 2003-05-01

    Logged In: YES
    user_id=736

    0.4.x is old, try 0.6.x or above should not have the problem.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks