Site Creation Woes | Software Config | FTP

Help
MojoRyssen
2006-09-03
2013-04-11
  • MojoRyssen

    MojoRyssen - 2006-09-03

    hi. i am having serious issues with configuring Screem to function properly. This shouldn't be such an issue for me-- i mean, i'm expeienced w/ FTP, server admin, etc-- but i "just don't get it".

    the software seems to be setup intuitively enough, so i get in there and try to setup a site. i've got a few "under development sites" on my remote server, so this should be plenty to work with. just small sutff, a few files, couple images, css file. i think i'm able to get the FTP thing going so it's connecting to the remote-- but it's difficult to tell what's goign ont. i'm running on apache, Fedora COre 5. let's say i've downloaded a file from ftp:// ... and i'm editing it. then i want to preview it. this is where i get confused because it views the file, instead of putting the modified file on the server as i'd expect, what goes up in the browser (external browser, for example) has a URL of:
    file:///var/www/html/MyFolderLocal/myFile.php -- which is NO GOOD at all because the PHP isn't parsed, but instead Firefox wants to save the file. see what i mean?

    i tried different ways of getting into the site dialogue-- by following the documentation (doc's done rather well, i might add-- Kudos!), but every time i seem to end up back at the file:// URL when i'm previewing, OR if i do get the remote view, by specifically selecting View > Preview on Server
    For as advanced an IDE as this is, and how great it's setup, it's terribly frustrating that something as simple as http://localhost/MyFolder/myfile.php  can NOT be achieved no matter what i've tried! but, w/out that URL, it does me no good. i can't test php any other way-- and i shouldn't have to workaround it. i just don't get it. does anyone have a more detailed walkthrough on the setup?

    is it possible that this could some how be an SELinux issue? NOTE: i am able to use http://localhost/mysite... all the time w/ gedit, or bluefish, or etc. -- so, i wanted to try something which look a little more up my alley (although i like bluefish a lot)...
    for the record, i spend the same several frustrating hours w/ the same maddening complications yesterday which trying to get Quanta Plus to work.

    am i alone out here in my woes? or am i just overlooking something?

    thanks!

     
    • David A Knight

      David A Knight - 2006-10-11

      You need to be working on a site rather than individual files.

      1) Go to the site menu and select site settings.
      2) Click the Publishing tab

      here you can enter the base url the site can be viewed at from the preview on server menus.

      There shouldn't be an issue with SELinux at all.

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks