Derek Tombrello - 2009-02-02

I am new to Linux, so I may be overlooking something. I try to run the ./configure command and I get this:

checking for GLIB - version >= 2.5.6... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB is incorrectly installed.
configure: error:
*** GLIB 2.5.6 or better is required. The latest version of
*** GLIB is always available from ftp://ftp.gtk.org/

I have read a similar post to this where the response was that the dev files were not installed. Here is a list of what I currently have installed related to GLIB...

Ubuntu v8.10

libpoppler-glib3   v0.8.7-1ubuntu0.1
libglibmm-2.4-1c2a   v2.18.1-1
libndesk-dbus-glib1.0-cil   v0.4.1-1
libavahi-glib1   v0.6.23-2ubuntu2.1
libnm-glib0   v0.7~~svn20081018
libdbus-glib-1-2   v0.76-1
libgnomecups1.0-1   v0.2.3-2build1
libglib1.2ldbl   v1.2.10-19build1
libglib2.0-cil   2.12.1-1ubuntu2
libglib-perl   v1:11.183-1
libglib2.0-0   v2.18.2-0ubuntu2
libglib2.0-data   v2.18.2-0ubuntu2
libglib2.0-dev   v2.18.2-0ubuntu2
linux-libc-dev   v2.6.27-11.27
python-gobject   v2.15.3-0ubuntu5
libnss-mdns   v0.10-3ubuntu2
libggz2   v0.0.14.1-1build1
libdbus-1-3   v1.2.4-0ubuntu1
dbus   v1.2.4-0ubuntu1
libsoup2.4-1   v2.24.1-0ubuntu1

As a newbie, I obviously have no clue what those mean, but I would think that the libglib2.0-dev package would satisfy the GLIB2.5.6 requirement. If someone could please look at this and let me know what I am missing and, if possible, how to install/upgrade it?

I am trying to migrate from Win98 to Ubuntu and I am trying to install Screem as a replacement for two programs that I have been using to design my website - HTML-kit and Notepad++.

Thanks in advance for your help!

---
Derek Tombrello
http://www.RobotsAndComputers.com