will not start

  • subtropolis

    subtropolis - 2006-12-08

    Fedora Core 4

    # yum install screem
    /usr/share/gnome/help/screem/C/screem.xml:17: I/O warning : failed to load external entity "/usr/share/sgml/docbook/dtd/xml/4.1.2/docbookx.dtd"

    Installed: screem.i386 0:0.14.1-1.fc4

    When attempting to get the app to start, i get the following msg:
    -- snip --
    Screem was unable to locate one of its files.

    The default configuration could not be found, this means that screem doesn't appear to have been installed correctly and can not continue.  If you have just installed screem then try restarting gconfd.
    -- snip --

    I tried the following hint about gconftool-2:


    (note that there's a typo: schemeas should be schemas)

    It says to set GCONF_CONFIG_SOURCE as root. However, shouldn't i be setting this in my bashrc as a regular user? Does it even need to be set every time i log in?

    This output a bunch of stuff about "Installed schema" and it seemed to be ok. However, i am still receiving the same error msg.

    I tried starting the app as root and received a different msg:
    -- snip --
    User session bus not available

    Unable to determine the address of the message bus

    Debian users should add "use-session-bus" to /etc/X11/Xsession.options
    For other distributions read 'man dbus-launch'
    -- snip --

    This time, however, the app starts. Still no luck as a regular user.

    Can anyone decipher this? I have no idea hgow i should use dbus-launch (nor if i even need to).

    • subtropolis

      subtropolis - 2006-12-08

      I forgot to mention that i could't figure out how to restart gconfd. The man page simply says of the --shutdown option that one should only use it if one has a good reason. Not very helpful at all. It turns out that that is how one restarts gconfd. Really unhelpful.

      Anyhoo, that did the trick.

      Now, about the name: screem?


Log in to post a comment.