Could not run GLIB test

  • Russ

    Russ - 2004-06-11

    I am new to Linux and have downloaded the Screem program to install.

    When I try to run "./configure", I get the following message.

    *** Could not run GLIB test program, checking why...
    *** The test program failed to compile or link. See the file config.log for the
    *** exact error that occured. This usually means GLIB is incorrectly installed.
    configure: error:
    *** GLIB 2.0.0 or better is required.

    I have the following GLIN components installed:
    Name: glibc-devel
    Version: 2.3.3-10mdk

    Name: glibc-doc
    Version: 2.3.3-10mdk

    Name: glibc-doc-pdf
    Version: 2.3.3-10mdk

    Name: glibc-i18ndata
    Version: 2.3.3-10mdk

    Name: glibc_lsb
    Version: 2.3.1-1mdk

    Name: glibc-profile
    Version: 2.3.3-10mdk

    Name: glibc-static-devel
    Version: 2.3.3-10mdk

    Name: glibc-utils
    Version: 2.3.3-10mdk

    Name: glib-gettextize
    Version: 2.2.3-1mdk

    Can you tell me why this won't run? Please remember I 'm a Linux newbie, so please keep it simple.


    • David A Knight

      David A Knight - 2004-06-11

      you need glib-devel  >= 2.0.0,  glibc is something else.  You will probably encounter other problems with missing -devel packages.  The configure script will say which ones.

      • Paul Troke

        Paul Troke - 2005-07-19

        I have come across the same error and downloaded and installed the latest version of GLIB, which is 2.7.3, but I still encounter the same error when attempting to configure screem.

        Any ideas?

    • David A Knight

      David A Knight - 2005-07-19

      same reason, either you don't have the development package installed, or if you installed 2.7.3 from source you installed it to a different prefix, in which case you will need to set PKG_CONFIG_PATH to include the directory where glib-2.0.pc can be found.

  • Roger Penn

    Roger Penn - 2010-12-14

    It's now over 5 years since you said the latest version of GLIB is 2.7.3 and the latest version I can find anywhere on the Internet is 2.2.26. Where on earth do you find >2.5.6?


Log in to post a comment.