I am new to Linux and have downloaded the Screem program to install.
When I try to run "./configure", I get the following message.
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB is incorrectly installed.
*** GLIB 2.0.0 or better is required.
I have the following GLIN components installed:
Can you tell me why this won't run? Please remember I 'm a Linux newbie, so please keep it simple.
you need glib-devel >= 2.0.0, glibc is something else. You will probably encounter other problems with missing -devel packages. The configure script will say which ones.
I have come across the same error and downloaded and installed the latest version of GLIB, which is 2.7.3, but I still encounter the same error when attempting to configure screem.
same reason, either you don't have the development package installed, or if you installed 2.7.3 from source you installed it to a different prefix, in which case you will need to set PKG_CONFIG_PATH to include the directory where glib-2.0.pc can be found.
It's now over 5 years since you said the latest version of GLIB is 2.7.3 and the latest version I can find anywhere on the Internet is 2.2.26. Where on earth do you find >2.5.6?
Log in to post a comment.
Sign up for the SourceForge newsletter:
You seem to have CSS turned off.
Please don't fill out this field.