Help save net neutrality! Learn more.

libcroco version issues on Fedora Core 1

  • J. J. Ramsey

    J. J. Ramsey - 2004-03-30

    I tried compiling Screem on Fedora Core 1, only to find that Screem appeared to require libcroco 0.4.0. This is problematic because there are pieces of Fedora that require libcroco 0.3.0.

    Any good workarounds for this?

    • Michael Hutchins

      Use yum to install.  It will take care of any dep's

      • J. J. Ramsey

        J. J. Ramsey - 2004-04-01

        "Use yum to install. It will take care of any dep's"

        I know about yum, thank you very much, and if it were that simple I wouldn't be posting to this forum. Yum is only as good as the repositories available to it, and unfortunately, there doesn't appear to be a yum repository for Fedora Core 1 that *has* libcroco-0.4.0 or libcroco-0.5.0.

        Specifically, the package librsvg2 depends on certain files in the libcroco-0.3.0 package that aren't in libcroco-0.4.0 or later, and the eel2 and gdm packages, which are fairly critical, both depend on librsvg2.

        So I ask again, any good workarounds for this?

    • David A Knight

      David A Knight - 2004-04-01

      libcroco 0.5.0 is recommended, which also requires screem 0.10.1 as there was a bug in 0.10.0 that prevented it compiling with 0.5.0 of libcroco.

      With versions of libcroco prior to 0.5.0 the css tree view may not build completly if properties such as -moz-border-radius are used, or @import is used.  There are also a couple of lockups that occur in versions prior to 0.5.0.

    • J. J. Ramsey

      J. J. Ramsey - 2004-04-03

      I think I figured out how to do it. I installed libcroco-0.5.0 to /opt/libcroco05, then ran ./configure with the argument "PKG_CONFIG_PATH=/opt/libcroco05/lib/pkgconfig".

      Screem seems to run fine.


Log in to post a comment.