#281 At least a dictionary is needed

open
None
5
2006-12-06
2006-11-20
No

screem version: 17.1.1 + cvs as of November, 20th 2006
system: Mac OS X 10.4.8
options: mozilla disabled, enchant enabled, dbus disabled

When quitting screem, a Gtk critical is emitted if no dictionary is installed:

enchant_broker_free_dict assertion dict failed

Not sure how it is for other systems, but on fink, installing aspell does not install any dictionary, hence the critical warning.

Installing aspell-en, even on a non English system, gets rid of this warning.

Would it be a way to free the dictionary only if it is actually installed on the system?

Discussion

  • David A Knight

    David A Knight - 2006-12-03

    Logged In: YES
    user_id=736
    Originator: NO

    yes it should only free it if one is there, this was a deeper problem actually as the spell checking code didn't bother to see if it obtained a dictionary. should now be fixed in cvs

     
  • David A Knight

    David A Knight - 2006-12-03
    • assigned_to: nobody --> davek
    • status: open --> open-fixed
     
  • Anonymous - 2006-12-04

    Logged In: YES
    user_id=552580
    Originator: YES

    Yes, it is fixed now. Thanks.
    Works with or without dictionary installed and with no warnings, and also works with custom words list, great.

     
  • Anonymous - 2006-12-04
    • status: open-fixed --> closed-fixed
     
  • Anonymous - 2006-12-06
    • status: closed-fixed --> open
     
  • Anonymous - 2006-12-06

    Logged In: YES
    user_id=552580
    Originator: YES

    I reopen the bug since it does not work completely.

    It crashes the first time screem is installed and launced.
    Thereafter it works fine.

    It seems that it is related to what is written in home/.screem/, since I can reproduce it reliably removing that directory. The only changes between first launch and subsequent one in that directory are two new files implemented in subsequent launch:
    accels and session_last_xml

    session_last_xml is as following:
    <?xml version="1.0" ?>
    <screemsession><site url=""><pages name="fixme"><page url=""/></pages></site><window name="fixme" x="719" y="135" w="600" h="484" max="0"><site name="" /></window><hints x="0" y="0"/></screemsession>

    File Added: screem-dictionary-crash.txt.bz2

     
  • Anonymous - 2006-12-06

    Crash report when launching the first time with no dictionary installed

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks