#730 SciTE and KOffice

Bug
closed-fixed
SciTE (627)
3
2016-03-15
2008-09-24
barcaroller
No

This may be as much a KOffice bug as a SciTE bug; I will report it with KOffice too.

It seems you cannot copy&paste from SciTE to a KOffice text document. Nothing happens. To work around it, I have to copy&paste from SciTE to any other text editor (KEdit, KWrite, gEdit,...) and from there into KOffice.

Notes
-----
- This applies only to KOffice, not OpenOffice on KDE.
- It makes no difference whether I use copy/paste from the menu or Ctrl-C/Ctrl-V on the keyboard.
- The reverse works fine; I can copy&paste from KOffice to SciTE.
- Using SciTE 1.74 and KOffice 1.6.3 on Fedora 8 (32 bit) with KDE 3.5.

Discussion

  • Neil Hodgson

    Neil Hodgson - 2008-10-04
    • priority: 5 --> 3
    • assigned_to: nobody --> nyamatongwe
    • status: open --> open-accepted
     
  • Neil Hodgson

    Neil Hodgson - 2008-10-04

    There is a good chance that this is something that SciTE could fix if someone could work out what KOffice is expecting. Possibly it wants or doesn't want a particular terminating character on the clipboard or a particular format. Since I use OpenOffice, I'm not going to work on this.

     
  • Johannes Sasongko

    Copying from SciTE to Calligra Words (the current incarnation of KWord) works fine, so I guess this got fixed at some point (either on SciTE's end or Words').

     
  • Neil Hodgson

    Neil Hodgson - 2016-03-15
    • status: open-accepted --> closed-fixed
     
  • Neil Hodgson

    Neil Hodgson - 2016-03-15

    Yes, appears to work now with Calligra Words, so closing as fixed.

     

Log in to post a comment.