#1366 File erased by SciTE on save action

Bug
open
SciTE (626)
6
2016-01-06
2012-05-24
No

I'm using SciTE 3.1.0 on Linux (Fedora 16) . Sometimes I can't save files. On save action, SciTE show the dialog box "The file ... is already being saved." but it's false. The file is not saved and SciTE is completely broken. All other actions such as Quit, Save as..., etc. are refused. So the only possibility to quit SciTE is to kill the SciTE process. But after that, the file to save is completely erased (zero size) !

This problem has occured several times with small files (less than 20K bytes) since I've installed the 3.1.0 release and before I was using the 3.0.3 release. So I think a bug has been introduced in the 3.0.4 release on the new fonctionnality : save on background.

I'm using SciTE since several years but it is the first time, I lost files with this editor. Because of that, I can't no more rely on SciTE and I switched back to more reliable editors such as gedit.

Discussion

  • Neil Hodgson

    Neil Hodgson - 2012-05-25
    • assigned_to: nobody --> nyamatongwe
    • priority: 5 --> 6
    • milestone: --> Bug
     
  • Neil Hodgson

    Neil Hodgson - 2012-05-25

    Background saving should be turned off for small files on Linux with the line background.save.size=10000000 in SciTEGlobal.properties . If you check the value of this variable by typing "echo $(background.save.size)" does it show 10000000?

    I would like to reproduce this bug and fix it but have not been able to so far.

     
  • Neil Hodgson

    Neil Hodgson - 2012-05-25

    The "echo $(background.save.size)" command should be typed in the output pane.

     
  • Philippe Berthault

    I haven't specifiy background.save.size in the SciTEGlobal.properties, so the default value is used.

    Thanks for your comment, I will define background.save.size with a big value and retry to use SciTE.

     
  • Neil Hodgson

    Neil Hodgson - 2012-05-25

    That should have appeared in global options when installing 3.1.0. You should only make your own changes in user options and use the global options as distributed.

    For my purposes, it would help to leave the setting and try to work out if there are particular circumstances to the failures. My best current theory is that since forking and threads don't mix well, the failure is due to executing a command within SciTE, which causes SciTE to call fork, leaving some part of the C runtime locked.

     
  • Philippe Berthault

    Because I have deeply customized SciTE for my needs, when I get a new version of SciTE, I install only executable and I keep properties files and lua scripts I have already customized. So when a now property appears in SciTE, this property isn't defined in the property files I use.

     
  • Neil Hodgson

    Neil Hodgson - 2013-01-07

    Committed change set [2ca8a8] which improves behaviour when loading more documents than buffers.

     

    Related

    Commit: [2ca8a8]

  • Neil Hodgson

    Neil Hodgson - 2013-01-17

    Status should really be open-fixed-maybe.

     
  • Neil Hodgson

    Neil Hodgson - 2013-01-17
    • status: open --> open-fixed
     
  • Neil Hodgson

    Neil Hodgson - 2013-06-12
    • status: open-fixed --> closed-fixed
     
    • Bernd Schneider

      Bernd Schneider - 2015-12-11

      I just had the same problem. I had to kill the Scite process in Windows 10 (v. 3.4.4). The file that was open at that time was completely erased (0 byte). Which is to say that I have to re-write an entire project.

       
      • Neil Hodgson

        Neil Hodgson - 2015-12-13

        Sorry about your file loss.

        Some more information could help find the problem that caused this. Was the file on a remote (networked) system or on a removable drive like a USB stick? Were there large files being edited or any oher reason for memory to be low? Had many files been opened and had any been automatically closed during this session? Was the disk space low?

         
  • Neil Hodgson

    Neil Hodgson - 2015-12-13
    • status: closed-fixed --> open
     
  • Philippe Berthault

    Hello,
    I've seen this old (2012) problem has been reopened by another user. FYI, with the property "background.save.size=10000000", the problem is never reappeared.
    Regards.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks