SchemeWay Eclipse 3.3

  • nimish123

    nimish123 - 2007-09-23

    I added the schemeway update site to eclipse and it downloaded and installed schemeway but I have no way of creating a schemeproject or anything; it's as if nothing changed at all. I can't open a scheme perspective or anything but the files are in the eclipse folders.

    • Dominique Boucher

      When you select the Help/About Eclipse Platform menu item, and click on "Plug-in Details", do you have SchemeScript in the list of available plug-ins? If not, then it is not properly installed.

      Note that there is no such thing as a Scheme project. There is, however, a Scheme perspective. Do you have a Scheme section in the Preferences?

      What is you operating system? Which version of SchemeScript did you install?


    • nimish123

      nimish123 - 2007-09-24

      My eclipse is 3.3 running on Vista Ultimate using SchemeWay 1.2.15 which was automatically installed by Eclipse from the update site. In the org.schemeway.plugins.schemescript_1.2.15 folder there are files including a schemescript.jar folder but I don't see anything in the PlugIn Details or the preferences.

      • Dominique Boucher

        Is there something in the Error Log View that relates to SchemeScript? A stack trace or something?

        Also, try restarting Eclipse with the -clean option.


    • Gansito Frito

      Gansito Frito - 2007-10-13

      I have the same problem with eclipse 3.3 on both Windows XP and Ubuntu.

    • Ima Mechanique

      Ima Mechanique - 2007-11-08

      Having the same problem.
      Eclipse 3.3.1
      Windows XP Pro 64 Bit Edition

      I've tried removing and installing again, using "-clean", and everything else you've suggested.  SchemeWay is listed under "Managing Configuration" but not in plug-ins and no perspective is available for it.

      • Dominique Boucher


        Can I send you (to your sourceforge email address) the latest (unofficial) version of SchemeScript to see if you have the same problem? I have just installed Eclipse 3.3.1 and everything works fine for me. The only difference is that I don't have the 64 Bit Edition of Windows XP Pro.

    • Dominique Boucher

      Can you all try to download the plugin from the download section of this site instead of using the update site? There may be some differences in the way the update site works in 3.3 that I was not aware of. If that does not work, I could send you an alpha version of the upcoming release.

    • Luca Paoli

      Luca Paoli - 2007-11-20

      Hi all,
      I can see schemescript in the list of installed plug-ins but when i try to open a *.scm file I get this error: "Unable to create this part due to an internal error. Reason for the failure: The editor class could not be instantiated. This usually indicates that the editor's class name was mistyped in plugin.xml."
      I tried to have a look at plugin.xml in the workspace folder but doesn't make much sense to me.
      How could I fix that?


    • Dominique Boucher


      I just tried installing SchemeScript 1.3.0 alpha 2 on a fresh install of Europa (3.3) and everything worked great. Maybe something wrong happened when you downloaded the file?

      BTW, the MD5 sum of the jar file is: 560dd4d5a209ea822dbc3de543940b13. The size is: 3301195 bytes.

    • Lothar May

      Lothar May - 2007-11-25

      I installed SchemeScript 1.3.0 alpha 2 on Eclipse 3.3 (MacOS 10.5) and it does not load. I tried "eclipse -clean". In the configuration details (About Eclipse Platform - configuration details) it is shown in the list of "Configured plugins" but this is the only sign of it. No properties, no perpective, not listed in the list of plugins.

      Am I doing anything wrong? Are there any dependencies which need to be met?

      • Dominique Boucher


        are there any entries relating to SchemeScript in the Error View? Maybe SchemeScript is conflicting with another plugin. Do you have the JDT (Java Development Tools) and the PDE (Plugin Development Environment) plugins installed?

        • Lothar May

          Lothar May - 2007-11-26

          I'm using the prebuilt C++ version of Eclipse, without Java development, so I do not have JDT or PDE installed (as far as I know). Do I need to install these packages?

          I cannot find any SchemeScript related error message in the error view :-(.

          • Dominique Boucher


            Yes, you need to install them. It seems that the PDE is an unnecessary dependency, but it made its way to the build... I just removed it so the next release will fix part of the problem.

            In the case of the JDT, removing the dependency would require much more work, as it is used for the code completion tool. But it's certainly doable. It's true that not all Scheme developers are using Eclipse for Java development...

            I will add a note to the release notes about those dependencies.


            • Lothar May

              Lothar May - 2007-11-27

              Hi Dominique,

              thanks for the hint, it is working now, after I installed the packages. Installing them is no problem (so removing the JDT dependency would not be absolutely necessary in my opinion), but it would be great to point out clearly visible which packages are needed.

              Anyway, thank you very much for the plugin, I use it with guile and it works like a charm. I like it.

              Best of luck to you,



Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks