failed to query graphviz..

gank211
2009-02-12
2013-05-29
  • gank211

    gank211 - 2009-02-12

    SchemaSpy is returning the following errors:

    Failed to query Graphviz version information: java.io.IOException: Cannot run pr
    ogram "dot": CreateProcess error=2, The system cannot find the file specified

    When I run dot -V I get
    dot - Graphviz version 2.20.3 <Wed Oct 8 06:02:12 UTC 2000>

    So it's in my path

    There are other errors that involve not being able to find the database but I think I know what the problem is there. i suppose these errors are not in anyway related.

     
    • John Currier

      John Currier - 2009-02-12

      I've seen problems where dot is in your path but it's not visible to java until after a system restart.  Some flavors of java have a small piece of code that's always loaded so the jvm will load quicker, but a side-effect of that is that changes to the environment aren't immediately visible.  Try restarting your computer and see if that helps.

      John

       
      • NixyJ

        NixyJ - 2009-02-18

        Hi there,

        A total newbie here but with the exact same error....

        So, I have a folder. c:\schemaspy which contains
        schemaSpy_4.1.1.jar
        postgresql-8.3-604.jdbc4.jar
        schemaSpy_4.1.1.source.jar

        I have also downloaded the GraphVis 2.20.3.1.msi and installed, using c:\schemaspy as the install location

        Then I have also copied the file dot.bat from the bi subdirectory into c:\schemaspy

        I'm then running....

        java -jar C:\schemaSpy\schemaSpy_4.1.1.jar -cp C:\schemaSpy\postgresql-8.3-604.jdbc4.jar -t pgsql -db lmdatabase -s public -host 192.168.21.129 -port 5432 -u usernji -p password -o C:\outputsspy

        and getting the error
        "Failed to query Graphviz version information: java.io.IOException: Cannot run program "dot": CreateProcess error=2, The system cannot find the file specified"

        Then it goes about its business, generates the majority of the output but then reports
        "Warning: Failed to run dot.
           Download dot version 2.2.1 or versions greater than 2.4
           from www.graphviz.org and make sure that dot is in your path.
           Generated pages will not contain a diagramtic view of table relationships."

        I know I must be doing something really stupid, I've tried installing Graphviz all over the place, rebooted multiple times and I'm just bamboozled....

        Please can anyone help - I'm going crazy!!

        Many thanks,
        N

         
        • John Currier

          John Currier - 2009-02-19

          When you installed Graphviz it should have added its bin directory to your path.  After removing dot.cmd (which from what I can tell doesn't exit) from your \schemaspy directory you should be able to type

          dot -V

          in a command window and see some meaningful output.  If it fails to find it then the Graphviz installer is most likely failing somehow.  For simplicity it's easiest to just reboot after installing Graphviz so that the new path can be seen by everything on your system.  Copying the dot executable to the current directory is unlikely to work.

           
  • va_a

    va_a - 2011-08-04

    Hi,
    Can anyone help me? So do I. I have also nstalled graphviz-2.29.20110726.0445.msi and I used ora for my dbtype. But still error :
    "Failed to query Graphviz version information with dot -V
    java.io.IOException: Cannot run program "dot": CreateProcess error=2, The system cannot find the file specified"
    I have tried in my cmd : java -jar schemaSpy_5.0.0.jar -t ora ….
    Still cann't run. Can you help me? How can I solve that? Thanks for your help ^^

     
  • John Currier

    John Currier - 2011-08-05

    Did you try running

    dot -V
    

    from the command line?

    There's also a -gv option that you can use to point to the directory that you installed Graphviz in.

    John

     
  • kpk

    kpk - 2012-07-28

    Hi,
    I just started using SchemaSpy yesterday (on Windows7 with postgresql 9.1).
    I downloaded the schemaSpy_5.0.0.jar from sourceforge.
    I have also downloaded and installed graphviz-2.28.0.msi from the graphviz.org website (Graphviz program folder is "C:\Program Files\Graphviz 2.28").

    When I run schemaSpy, it is generating the schema details for the database-schema selected, except the relationship diagram.
    On the relationship HTML page, it says "SchemaSpy was unable to generate a diagram of table relationships.
    SchemaSpy requires Graphviz version 2.2.1 or versions greater than 2.4 from www.graphviz.org. "

    When I checked the command line messages, I saw that there was a warning:
    "Writing/graphing summary….
    Warning: Invalid version of Graphviz dot detected (1.8.10).
       SchemaSpy requires dot version 2.2.1 or versions greater than 2.4. from www.graphviz.org.
       Generated pages will not contain a diagramatic view of table relationships……(0sec) "

    Also when I checked the dot version (as mentioned in this forum) using the dot -V command, it says
      dot version 1.8.10 (11/26/02)
    Is it some problem with the installation. Or is it standard to have dot 1.8 with Graphviz 2.28? Or do we need to do some manipulation of files?
    Pls help..

    regards
    kpk

     
  • Amit

    Amit - 2012-08-10

    Restart you system after installing the GrapViz, Then at cmd prompt execute the command >   dot -V
    if command displays the information then you are good. execute you schemaspy cmd as normal.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks