Oh, no, not again.

The bad news is that this kind of thing is binary-dependent, in that
the hash codes for wrappers are randomly assigned (though in one
binary, at least predefined hash codes are consistent).
some more info: (levy and me are working on the same project...)
if you mean sbcl binary, then the same thing happens for me on a 0.9.x (probably 11) linux x86-32 sbcl.
when i've seen these -3's, sometimes it was happening only for the first time i've tried to compile/load someting. in fact if asdf had a compile/load restart (as opposed to load only) then it would probably work for the second try without a vm restart.
i've tried to debug it when i first saw this bug, but it looks like the actual bug (or someting that triggers it) is decoupled much ealier. (as far as a lisp noob can see... :) maybe some asserts could be inserted somewhere that would help?
but it's sleep time here. we'll be online tomorrow eu time for an irc/skype/vnc/whatever session if that helps.
- attila
(alias 101 on irc &no 'its not lisp code :)