On Fri, Jun 18, 2010 at 5:11 PM, GreyHat LispHacker <greyhatlisphacker@gmail.com> wrote:

I am using Ubuntu 9.04, and had installed an older version of SBCL (1.0.18) from the Debian repositories. 

I recently built the newer SBCL version (1.0.38) from source, followed the directions available, and got it up and running.

I had tried to "debanize" the newer version of SBCL using the Debian CL Guidelines,

but get the following error when I try to compile the ASDF system

We had the same problem in Fedora.  Rex Dieter fixed it by patching common-lisp-controller, specifically /usr/share/common-lisp/source/common-lisp-controller/post-sysdef-install.lisp, so that the SBCL version of get-owner-and-mode looks like this:

(defun get-owner-and-mode (directory)
  (when (eq :directory
            (#.(or (find-symbol "NATIVE-FILE-KIND" :sb-impl)
            (find-symbol "UNIX-FILE-KIND" :sb-unix))
                (namestring directory)))
    ;; check who owns it
    (multiple-value-bind (res dev ino mode nlink uid gid rdev size atime mtime)
        (sb-unix:unix-stat (namestring directory))

      (declare (ignore res dev ino nlink gid rdev size atime mtime))
      (values uid mode))))

Jerry James