Error "unable to save settings"

Help
Laura
2008-05-01
2013-04-11
  • Laura

    Laura - 2008-05-01

    First I want to say,
    This is a great program!

    I installed this program on two machines in a classroom. The students liked it and had no trouble using the program!!

    The problem is that I received an error when I am logged in the machine as a student, (with limited privileges) and try to run the program. “Unable to save settings”

    I installed the program, per instructions given, under admin. Started and tested the program. Works great!  Logged off and logged on as the student. Error “Unable to save settings” 

    The funny thing is I installed it on another machine, exactly like it and it works. Installed it on an older machine and it worked. Installed it on a similar older dell and same error “Unable to save settings”  comes up.

    I am running Sayz Me on Dell Optiplex.
    I do have Fortres Grand software for security.  Thinking that this may be the problem, I even tried it on a new Dell Dual Core with 2 gig memory and NO Fortres Grand software and I still get the same error “Unable to save settings”.

    It seems to install and run under admin privileges just fine. I need it to run under the student login.

    What can I do or change that it will allow other user profiles in xp sp2 to “to save settings”

    Thanks for all the hard work on this program
    Laura

     
    • Tom Hall

      Tom Hall - 2008-06-08

      Hi Laura -

      First of all let me say that I'm not a member of this project so my advice should be taken with a grain of salt.

      I don't know what grade your students are, but if they're logging in, one of them may have enough computer savvy to be able to help with this, and enough curiosity to be motivated to.

      I also love this program - I use it all the time to turn stuff I get off the web into little "audio books" that I can listen to in my car.

      One of the greatest things about this program is you can get the source code - which is why I was here and happened to see your post - so if you have some computer savvy you can figure out these kinds of issues yourself. 

      But this can take a lot of time which is why I recommend you get one of your students to help for whom this would be an enjoyable hobby-type activity.

      Anyway, I searched the source ("sayzme.py"- comes in sayzme051_src.zip) and found that when you get this error, it's having a problem accessing the file "C:\Program Files\Sayzme\options", so you might try this:

      right-click on "C:\Program Files\Sayzme\options" in an explorer window, select "properties", then the Security tab, and give the students or student group write permissions to the file.

      I suspect that once you do this, if the problem does go away, you may find similar problems with other files in which case you can search the source, etc.

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks