I've started using the console plugin to jEdit as my usual command line environment, when I'm not executing things directly from the IDEA Java environment. Before that I used UltraEdit. I'm sure there are better ones, but anything reasonably modern should get the character encodings right. And logging the messages to a file should certainly be OK. In fact, the MSDOS console is the only place I've seen the problem.
 
Michael Kay


From: saxon-help-admin@lists.sourceforge.net [mailto:saxon-help-admin@lists.sourceforge.net] On Behalf Of Benson Cheng
Sent: 16 March 2004 17:17
To: saxon-help@lists.sourceforge.net
Subject: RE: [saxon] XQuery error message shows garbage characters

So is there work around for this?  e.g. which "more capable environment" should I use under Windows XP?  
 
Another question is if our application log these messages and display them in a web browser later, are they readable through the browser?
 
thanks for your help.
Benson.
-----Original Message-----
From: Michael Kay [mailto:mhk@mhk.me.uk]
Sent: Tuesday, March 16, 2004 12:43 AM
To: saxon-help@lists.sourceforge.net
Subject: RE: [saxon] XQuery error message shows garbage characters

Saxon is using some non-ASCII characters in its messages. It seems, sadly, that there are still systems around that can't cope with this, and that display them incorrectly. It seems to happen in particular if you use a raw MSDOS-style console. I haven't yet decided whether to encourage people to move to a more capable environment, or whether to resign myself to living within the constraints of 7 bit characters.
 
Michael Kay


From: saxon-help-admin@lists.sourceforge.net [mailto:saxon-help-admin@lists.sourceforge.net] On Behalf Of Benson Cheng
Sent: 16 March 2004 01:06
To: saxon-help@lists.sourceforge.net
Subject: [saxon] XQuery error message shows garbage characters

Hi All,
 
I just start using the Saxon 7.9 for processing the XQuery, when I use the command line to run some queries, the syntax error messages shows some garbage characters, can anyone help me to resolve this problem?  Here are some examples characters, I am running on Windows XP with JDK 1.4.2_03.
 
D:\work\xquery>java net.sf.saxon.Query -T Benson.xquery fromFileName=Input.xml
Error
  XQuery syntax error on line 6 in ½...t() { return <test> <╗:
    expected ½}╗, found ½">"╗
Failed to compile query: Query Parsing failed
Query processing failed
 
thanks,
Benson.