Thank Michael,
I am going to try some java programmers today since I can load the class now and it does work (except for the silliness with having to put the punctuation on the same level as the letter O). If you are interested in the resolution (if I get one), let me know and I will pass it on to you.
Thanks so much for your help,
Mark

From: Michael Kay
Sent: Wednesday, July 16, 2008 1:12 AM
To: 'Mailing list for the SAXON XSLT and XQuery processor'
Subject: Re: [saxon] collation problem

I don't immediately know the answer and I've got limited internet access today to research it for you.
 
I would strongly suggest testing your collation class before trying to invoke it from Saxon. To do this add a method
 
public static void main(String[] args) throws Exception {
    System.err.println(new CzechCollation().compare(args[0], arg[1]));
}
 
and you will then be able to invoke your class directly from the command line, with two strings to be compared as arguments.
 
Michael Kay
http://www.saxonica.com/


From: saxon-help-bounces@lists.sourceforge.net [mailto:saxon-help-bounces@lists.sourceforge.net] On Behalf Of Mark Wilson
Sent: 16 July 2008 04:45
To: Mailing list for the SAXON XSLT and XQuery processor
Subject: Re: [saxon] collation problem

Hello, Tony.
That got me squared away. The collation class -- after some fiddling because of the error reported below -- now appears to work. However (and this is the wrong list to ask but I do not know where to go, can someone answer or point me there?), my fiddling made the error go away, but it seems somehow a very wrong fix.
-----------------------------
The Error:
C:\Users\HP\saxon>java -cp "C:\Users\HP\saxon\saxon9.jar;CzechCollation.jar" net
.sf.saxon.Transform -xsl:Authors2.xsl -s:SelectedAuthors.xml  1>Sorted.xml
Warning: Failed to instantiate class CzechCollation: missing chars (=,;<&): < P,
p < Q,
Warning: Failed to instantiate class CzechCollation: missing chars (=,;<&): < P,
p < Q,
Error at xsl:copy on line 17 of Authors2.xsl:
  XTDE1035: Unknown collation http://saxon.sf.net/collation?class=CzechCollation
 
  in built-in template rule
Transformation failed: Run-time errors were reported
---------------------------------------------------
 I tried to put the missing chars below A,a, but it still failed. Then I put them below P,P [as the error message seemed to indicate and it failed UNLESS I put them on the same level as O,o
Worked: "<O,o, '(','=',',',';','&',')' < P,p."
Failed: "<O,o, < '(','=',',',';','&',')' < P,p."
 
Mark


-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/


_______________________________________________
saxon-help mailing list archived at http://saxon.markmail.org/
saxon-help@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/saxon-help