Hi there.

Sorry, it's me again. Thank you both for your kind help. But: Still no success.

My $JAVA_HOME is /usr/lib64/jvm/java.

But there are several files named
"libjvm.so" on my computer.

One in the folder
about 14 MB large

And one in the folder
"/usr/lib/rt/lib/amd64/jetvm/" about 22,8KB in size.

I tried both. And in order to make sure I have the right directory I set the links in lib, lib64 and /usr/lib.

But it didn't work.

So, I tried to build the extension again:

./configure --enable-saxon
export LD_LIBRARY_PATH=/usr/lib/rt/lib/amd64:$LD_LIBRARY_PATH
make install

Still the same: on each re-boot:
"PHP Startup: Unable to load dynamic library '/usr/lib64/php5/extensions/saxon.so' - libsaxon.so: cannot open shared object file: No such file or directory in Unknown on line 0"

Maybe the problem is in the LD_LIBRARY_PATH.

There is a folder named "/usr/lib/rt/lib/amd64" on my machine.
But in the script of Petr Zak you send me, Oneil, the corresponding line is
"export LD_LIBRARY_PATH=/usr/lib/rt/lib/amd64:/usr/lib/jvm/java-6-openjdk-amd64/include/linux:/usr/lib/jvm/java-6-openjdk-amd64/include:$LD_LIBRARY_PATH"
On my machine there is nowhere a directory called "java-6-openjdk-amd64".

Hope you know what to try next. I don't

Thanks in advance!