Following on from my last post, the other error I encountered today with Saxon9HE (version was as follows.

On certain XSL transformations in my application, I was receiving a StackOverflow Exception and a very long stack trace showing what looks like an infinite loop in the net.sf.saxon.expr.ExpressionTool class.

Curiously, this worked when I ran my web application in Tomcat inside Eclipse but when I ran it in Tomcat stand-alone, I ran into these stack overflows - even when processing very small XML with very small XSL templates.

The specific messages I received are (with a very large number of the line 825 reported). All the entries in the stack trace were these:

stackoverflow net.sf.saxon.expr.ExpressionTool.resolveCallsToCurrentFunction(
stackoverflow net.sf.saxon.expr.ExpressionTool.resolveCallsToCurrentFunction(

I was able to resolve this one by downloading and using the latest version of Saxon9HE version 9.2.

Again, has anyone seen this sort of thing before? Is it a bug or something to do with my configuration?




Jonathan Carter 
Enterprise Architecture Solutions Ltd

Proud sponsors of The Essential Project
The free open-source Enterprise Architecture Management Platform

Enterprise Architecture Solutions Ltd, Registered in England and Wales: 04097721.
Registered Office: 76 High Street, Newport Pagnell, Milton Keynes, MK16 8AQ.