I'm surprised that you found it necessary to uninstall one version of the JDK in order to install another. I always have half a dozen versions installed on my machine, it's needed for testing. I don't know Solaris, but I would imagine it's more flexible than Windows, not less.
I can't offer to try it out myself because it seems the problem is specific to Solaris. I think it's very unlikely that there is anything wrong with your computer (or with Saxon) - it's a JDK or JVM bug, almost certainly.
Michael Kay

From: Marijan (Mario) Madunic [mailto:hajduk@imag.net]
Sent: 21 November 2008 02:54
To: Mailing list for the SAXON XSLT and XQuery processor
Subject: Re: [saxon] Issue with large XML doc and crashes -- originally in XSLT mailing list


Needed to uninstall 1.6 to install 1.5. I ran it from the command line as follows

java -Xmx1272m -jar saxon9.jar -o temp/temp.xml doNotDelete/keep.xml xslChunks/fixTracks.xsl
and separately
java -Xmx1272m -jar saxon8.jar -o temp/temp.xml doNotDelete/keep.xml xslChunks/fixTracks.xsl

both crashed my computer.

So uninstalled 1.5 and reinstalled 1.6. Ran the above and saxon8 no problem but saxon9 this time crashed the computer.

I'm thinking that it is an issue with my computer.

Is the sql extension available with the free version of Saxon? I'd like to try this another way.

Tried using the stream extension but it is unavailable with the version of Saxon I'm using.