Ahh, this is a slightly worrying Email. I can already hear the boss faintly muttering that I should switch to using his beloved Altova.. As this is the build process from a separate group I have little control over the implementation used (except that my build.xml worked). The original Ant based build system I setup 2 years ago was running fine until the Japanese strings arrived and I was hauled in to fix my (not guilty) xslt scripts written at the same time. I had rather hoped that Mike would solve it for me. I had already tried the factory element and I can confirm that Mike’s supposition is correct – it is not supported - yet. Neither is my current favourite element ‘option’.


Many thanks for your help.




From: Michael Kay [mailto:mike@saxonica.com]
Sent: Monday, December 14, 2009 10:52 AM
To: 'Mailing list for the SAXON XSLT and XQuery processor'
Subject: Re: [saxon] saxon9-ant.jar options


The saxon9-ant task has proved somewhat troublesome, I'm afraid, because I have no effective way of testing it. It's supposed to inherit the functionality of the base xslt task where applicable, but that functionality is not especially well documented, and there's no public test suite to enable me to check that I haven't broken anything; moreover Ant is such a complex product with so many dependencies that I haven't actually managed to build it in my IDE, which makes it very difficult to investigate problems like this. That's why I pulled it out from the main product and now ship it only as a standalone "add-on".


Looking at the spec again, for the xslt task, "attribute" is a child of "factory", and I'm not sure the Saxon task accepts the factory element - it wouldn't make all that much sense.



Michael Kay


From: Heath, Graham [mailto:graham.heath@ts.fujitsu.com]
Sent: 14 December 2009 07:54
To: Mailing list for the SAXON XSLT and XQuery processor
Subject: Re: [saxon] saxon9-ant.jar options

Sorry Mike,


base.xml:111: saxon-xslt doesn’t support the nested „attribute” element.


A nested “param” element is accepted but does not appear to generate any tracing.


Just as an aside, I struggled to find any documentation for saxon9-ant.jar and all the variations of param that I could think of failed to deliver.

The original problem was that invoking Saxon using the “java” task corrupted the Japanese strings in the source XML. Using the “xslt” task fell foul of the Factory settings problem. Leading me to use the saxon9-ant task – this managed the transform without breaking the Japanese strings. Hooray, but I had wanted to see what additional information I could get by activating tracing..


Ciao Graham


From: Michael Kay [mailto:mike@saxonica.com]
Sent: Friday, December 11, 2009 10:53 PM
To: 'Mailing list for the SAXON XSLT and XQuery processor'
Subject: Re: [saxon] saxon9-ant.jar options


Hi Graham, sorry for the delay in responding.


If you are using the ant xslt task, or the Saxon AntTransform task derived from it, then the equivalent to the -T option on the command line is (in theory) to use a nested element


<attribute name=http://saxon.sf.net/feature/traceListenerClass"



I haven't actually tried it.


From: Heath, Graham [mailto:graham.heath@ts.fujitsu.com]
Sent: 08 December 2009 17:09
To: saxon-help@lists.sourceforge.net
Subject: [saxon] saxon9-ant.jar options

Hi guys, I am running the saxon9-ant.jar to invoke saxon from my ant script. The problem is that I wanted to activate the trace option and so far I have not stumbled on the right invocation.


Any help gratefully received.


Ciao Graham