I'm sorry, but I'm not clear what the problem is. Are you suggesting that Saxon reported an error when there was no error in your code? Or are you suggesting that Saxon's diagnostics for the error were misleading and could be improved?

Either way, to do anything about it, we will need a copy of the stylesheet that illustrates the problem.

Michael Kay
Saxonica

On 13/02/2012 14:57, Echlin, Robert wrote:

Hi

I am using Saxon 9.1.

I received this error, erroneously and time-wastingly attributed to the template match line:

  <xsl:template match="/">

It was actually due to an error in a line farther on, where I created a variable with nothing in it (instead of a file name) and then tried to create a "document" from a path that included that file name.

It's probably relevant that the document passed in was a dummy and the "match" was never used.

 

Is this known and fixed in later versions, or should I try to reproduce a failing code sample?

This file never hit SVN yet, so I don’t really have the failing copy after mucking with it.

 

Thanks,

Rob

 

--

Rob Echlin, Documentation Systems Architect, Wind River
+1.613.270.5796 | Skype: rob.echlin.wr | robert.echlin@windriver.com

WR Jive - https://communities.windriver.com/people/rechlin

 



------------------------------------------------------------------------------
Try before you buy = See our experts in action!
The most comprehensive online learning library for Microsoft developers
is just $99.99! Visual Studio, SharePoint, SQL - plus HTML5, CSS3, MVC3,
Metro Style Apps, more. Free future releases when you subscribe now!
http://p.sf.net/sfu/learndevnow-dev2


_______________________________________________
saxon-help mailing list archived at http://saxon.markmail.org/
saxon-help@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/saxon-help