This seems to be the same as another problem reported earlier today (off-list, but with a repro). It seems to be an error in the bug fix to

http://sourceforge.net/tracker/?func=detail&aid=3307404&group_id=29872&atid=397617

as the problem is apparently present in 9.3.0.8 but not in 9.3.0.5. I imagine differences you report are due to running different versions in different environments.

Michael Kay
Saxonica



On 16/11/2011 15:32, Jonathan Carter wrote:
Following on from my last post, the other error I encountered today with Saxon9HE (version 9.3.0.8) was as follows.

On certain XSL transformations in my application, I was receiving a StackOverflow Exception and a very long stack trace showing what looks like an infinite loop in the net.sf.saxon.expr.ExpressionTool class.

Curiously, this worked when I ran my web application in Tomcat inside Eclipse but when I ran it in Tomcat stand-alone, I ran into these stack overflows - even when processing very small XML with very small XSL templates.

The specific messages I received are (with a very large number of the line 825 reported). All the entries in the stack trace were these:

stackoverflow net.sf.saxon.expr.ExpressionTool.resolveCallsToCurrentFunction(ExpressionTool.java:816)
stackoverflow net.sf.saxon.expr.ExpressionTool.resolveCallsToCurrentFunction(ExpressionTool.java:825)
....


I was able to resolve this one by downloading and using the latest version of Saxon9HE version 9.2.

Again, has anyone seen this sort of thing before? Is it a bug or something to do with my configuration?

Thanks

Regards

Jonathan
_______________________________________

Jonathan Carter 
Enterprise Architecture Solutions Ltd
_______________________________________

Proud sponsors of The Essential Project
The free open-source Enterprise Architecture Management Platform
www.enterprise-architecture.org
_______________________________________

Enterprise Architecture Solutions Ltd, Registered in England and Wales: 04097721.
Registered Office: 76 High Street, Newport Pagnell, Milton Keynes, MK16 8AQ.



------------------------------------------------------------------------------
All the data continuously generated in your IT infrastructure 
contains a definitive record of customers, application performance, 
security threats, fraudulent activity, and more. Splunk takes this 
data and makes sense of it. IT sense. And common sense.
http://p.sf.net/sfu/splunk-novd2d


_______________________________________________
saxon-help mailing list archived at http://saxon.markmail.org/
saxon-help@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/saxon-help