All recent Saxon releases (certainly all releases that support XQuery) require JDK 1.4 or later.
 
You could use Saxon 6.5.5, and write the code in XSLT 1.0 rather than XQuery. But is there any good reason why you don't simply install JDK 1.5? It's perfectly possible for different applications on the same system to use different versions of the JDK, unless you're in some kind of web service or application server environment.
 
Michael Kay
http://www.saxonica.com/


From: saxon-help-bounces@lists.sourceforge.net [mailto:saxon-help-bounces@lists.sourceforge.net] On Behalf Of Chiang, Shirley (Shih-Chen)
Sent: 08 December 2006 20:20
To: saxon-help@lists.sourceforge.net
Subject: [saxon] Will saxon work

Hi All,

I need to write a parser to parse through a html file in order to retrieve certain name/value pair.  This parser will be invoked in java.  My problem is that our system is still using jdk 1.3.1.  This is kind of like screen scraping to get data.  Is there a way for me to use saxon xquery to do the job with jdk 1.3.1?

Thanks,