Hello, i'm trying to recompile two programs, dacapo benchmark and  polymer (a program used to enforce some security policies), so anyway, i get an error of loader constraint violation when precisely trying to compile eclipse in dacapo with polymer, below i'm listing the exact error log i receive and i was wondering what can i possibly do to solve the problem. 

thanks, soha


!SESSION 2010-07-22 17:05:29.514 -----------------------------------------------
eclipse.buildId=M20060118-1600
java.version=1.6.0_20
java.vendor=Apple Inc.
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US
Framework arguments:  -application dacapo.eclipse.dacapoHarness -level 0
Command-line arguments:  -data ./scratch/workspace -application dacapo.eclipse.dacapoHarness -level 0

!ENTRY org.eclipse.update.configurator 2010-07-22 17:05:29.608
!MESSAGE Could not install bundle plugins/org.eclipse.jdt.core.tests.builder_3.1.2/   loader constraint violation: when resolving method "javax.xml.parsers.SAXParser.parse(Ljava/io/InputStream;Lorg/xml/sax/helpers/DefaultHandler;)V" the class loader (instance of polymer/PolymerClassLoader) of the current class, org/eclipse/core/runtime/internal/adaptor/PluginParser, and the class loader (instance of <bootloader>) for resolved class, javax/xml/parsers/SAXParser, have different Class objects for the type org/xml/sax/helpers/DefaultHandler used in the signature

!ENTRY org.eclipse.update.configurator 2010-07-22 17:05:29.611
!MESSAGE Could not install bundle plugins/org.eclipse.jdt.core.tests.compiler_3.1.2/   loader constraint violation: when resolving method "javax.xml.parsers.SAXParser.parse(Ljava/io/InputStream;Lorg/xml/sax/helpers/DefaultHandler;)V" the class loader (instance of polymer/PolymerClassLoader) of the current class, org/eclipse/core/runtime/internal/adaptor/PluginParser, and the class loader (instance of <bootloader>) for resolved class, javax/xml/parsers/SAXParser, have different Class objects for the type org/xml/sax/helpers/DefaultHandler used in the signature

!ENTRY org.eclipse.update.configurator 2010-07-22 17:05:29.613
!MESSAGE Could not install bundle plugins/org.eclipse.jdt.core.tests.performance_3.1.2/   loader constraint violation: when resolving method "javax.xml.parsers.SAXParser.parse(Ljava/io/InputStream;Lorg/xml/sax/helpers/DefaultHandler;)V" the class loader (instance of polymer/PolymerClassLoader) of the current class, org/eclipse/core/runtime/internal/adaptor/PluginParser, and the class loader (instance of <bootloader>) for resolved class, javax/xml/parsers/SAXParser, have different Class objects for the type org/xml/sax/helpers/DefaultHandler used in the signature

!ENTRY org.eclipse.update.configurator 2010-07-22 17:05:29.621
!MESSAGE Could not install bundle plugins/org.eclipse.test.performance_3.1.0/   loader constraint violation: when resolving method "javax.xml.parsers.SAXParser.parse(Ljava/io/InputStream;Lorg/xml/sax/helpers/DefaultHandler;)V" the class loader (instance of polymer/PolymerClassLoader) of the current class, org/eclipse/core/runtime/internal/adaptor/PluginParser, and the class loader (instance of <bootloader>) for resolved class, javax/xml/parsers/SAXParser, have different Class objects for the type org/xml/sax/helpers/DefaultHandler used in the signature