web service call returns localhost:50000

  • woky

    woky - 2012-05-07


    thank you for doing this as open source SAP.

    We have NetWeaver 7.3 in our company.

    First of all I have an issue with Eclipse 3.7.2 and sapnweclipse (latest from updatesite). The login dialog reports invalid credentials for everything without sending anything to the NetWeaver server (I run wireshark in background).

    But I don't plan to use Eclipse plugin. I'd rather like to use core API.

    I've tried to list applications like this:

    server = new ServerImpl("", 0);
    server.getDeployManager().setAuthenticationCallback(new AuthenticationCallback() {
    public Credentials getCredentials(AuthenticationReason reason) throws CoreException, AuthenticationRefusedException {
    return new Credentials("Administrator", "secret");
    for (final Application app: server.getDeployManager().getApplications()) {

    This does 2-3 web service calls. The problem is that last call tries to connect to localhost:50000. This address is probably returned from previous web service call. I tried to forward this local port to remote port 50000 via SSH and it worked. It's not good solution though. Same happens with other methods (server lifecycle & deployment).

    Do you know which configuration in NetWeaver needs to be changed? I'm sorry but I'm very new to NetWeaver.

    Thank you.

  • Kaloyan Raev

    Kaloyan Raev - 2012-05-10


    Your situation looks really strange. Perhaps you are right this might be a wrong server configuration. Could you copy some of this wireshark output so I can also take a look at the communication between the IDE and the server.


  • Trisha Hart

    Trisha Hart - 2016-01-28

    Yep I can't make heads or tails of that it's an odd one alright


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks