Grid file could not be opened.

2014-04-16
2014-04-18
  • Bogdan Hlevca

    Bogdan Hlevca - 2014-04-16

    Hi,

    I worked a little sit SAGA and I like it. However, I have a problem. I cannot load any of the saved grids. I imported a geotiff and saved it as a sgrd files
    4 files are created

    MaxRate_april_june.mgrd 21 KB
    MaxRate_april_june.prj 512 B
    MaxRate_april_june.sdat 11.2MB
    MaxRate_april_june.sgrd 142 B

    Everything else seems to work. Unfortunately the error is too cryptic to reveal the cause.

    I tried a pre-compiled version 2.0.8 and I tried a 2.1.2 compiled by me. The behaviour is identical.

    Is there anything I can do to discover the problem. This is very annoying as I need to process the grid every time to change the colors the ranges, etc

    I am on Linux 64 bit. The compilation finished with no error and everything else seems to work fine..

    Thanks
    Bogdan

     
    Last edit: Bogdan Hlevca 2014-04-16
  • Ludwig Hilger

    Ludwig Hilger - 2014-04-16

    Dear Bogdan,

    nor wuite sure if I understand you problem, but the four files you listed are actually one single grid: Each Saga Grid consists of a .mgrd, .prj, .sdat and .sgrd. The actual file you want to open in SAGA is the *.sgrd.

    regards,
    Ludwig

     
    • Bogdan Hlevca

      Bogdan Hlevca - 2014-04-16

      Dear Ludwig,

      Thanks for replying. The problem is that the *.sgrd files are NOT loaded. The subject of this forum topic "Grid file could not be opened" is exactly what SAGA is printing out as an error every time I am trying to load a grid file.

      I listed all the files that were generated so that you know that I have there all the necessary files and that the problem is at load time.

      I was asking if there is anywhere where I can find a more useful debugging message that will help with understanding why the grid file is not loaded.

      Regards,
      Bogdan

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks