#137 Allow to build with system-wide e00compr and wxpropgrid

open
nobody
None
5
2016-03-08
2011-11-01
No

Please allow the user to let the build system use system wide libraries instead of the bundled ones.

Discussion

  • Volker Wichmann

    Volker Wichmann - 2012-04-24

    Next SAGA release (svn trunk) requires wxWidgets 2.9.3 which now includes wxpropgrid.

    Volker

     
  • Volker Fröhlich

    Hm, 2.9.3 is still considered "Development version" on http://www.wxwidgets.org/downloads.

     
  • Volker Wichmann

    Volker Wichmann - 2012-04-24

    Yes, our focus is on the next (3.0) release of wxWidgets, SAGA svn trunk will only compile with a wx version >= 2.9.3. I doubt that we will make the effort to "fix" this for SAGA 2.0.8.

    AFAIK, the e00 lib has several local fixes/adjustments in SAGA svn, but I will check this.

    Volker

     
  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here

    Anonymous - 2012-10-31

    g2clib is another bundle. It'd be good to use the latest system version, though that needs re-compilation.

     
  • Volker Fröhlich

    Any news about e00compr and g2clib?

    The only actual change I could spot is in e00compr.h in the placement of #ifdef __cplusplus and a missing definition of E00COMPR_VERSION.

    My builds succeed with g2clib 1.4.0 and e00compr 1.0.1.

     
    Last edit: Volker Fröhlich 2014-01-11
  • Volker Wichmann

    Volker Wichmann - 2014-02-11

    We would like to keep these libraries in the source code repository in order to facilitate the compilation of SAGA under Windows. As you seem to be able to build SAGA on Fedora with the system libraries, how about changing the linux build system to optionally allow the use of the system wide libraries instead of the bundeled ones? Would be great if you could provide a patch introducing some configure options to enable this.

     
  • Volker Fröhlich

    Yes, that was the original idea behind this report. Sorry if that wasn't clear!

    You can't make use of my current patching, otherwise I would have submitted it already. I'm not too good with Autotools, but I can try.

     
  • Volker Wichmann

    Volker Wichmann - 2014-02-11

    Would be great if you could give it a try! I'm not very familiar with autotools too and it always takes me a lot of time to get things right.

     
  • Johan Van de Wauw

    Note that a configure flag has been added in 2.2.4:

      --with-system_grib2c    Use system version of grib2c instead of embedded
                              copy, requires this library (and the header) to be
                              found.
    

    Other options you may be interested in as a packager are:

      --disable-triangle      Compile without triangle.c (only free for
                              non-commercial usage), and use qhull instead
                              (requires qhull)
      --disable-libfire       Compile without libfire (only free for
                              non-commercial usage)
    
     


Anonymous

Cancel  Add attachments





Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks