Command is:
$ s3cmd del --recursive --force s3://BUCKET/

And the error msg is:

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    An unexpected error has occurred.
  Please report the following lines to:
   s3tools-bugs@lists.sourceforge.net
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Problem: ExpatError: no element found: line 1, column 0
S3cmd:   0.9.9
Python:  2.6.2 (r262:71600, Sep 17 2009, 07:33:56)  [GCC 4.2.1 20070719  [FreeBSD]]

Traceback (most recent call last):
  File "/usr/local/bin/s3cmd", line 1562, in <module>
    main()
  File "/usr/local/bin/s3cmd", line 1542, in main
    cmd_func(args)
  File "/usr/local/bin/s3cmd", line 494, in cmd_object_del
    subcmd_object_del_uri(uri)
  File "/usr/local/bin/s3cmd", line 511, in subcmd_object_del_uri
    response = s3.object_delete(_uri)
  File "/usr/local/lib/python2.6/site-packages/S3/S3.py", line 217, in object_delete
    response = self.send_request(request)
  File "/usr/local/lib/python2.6/site-packages/S3/S3.py", line 391, in send_request
    e = S3Error(response)
  File "/usr/local/lib/python2.6/site-packages/S3/Exceptions.py", line 44, in __init__
    tree = getTreeFromXml(response["data"])
  File "/usr/local/lib/python2.6/site-packages/S3/Utils.py", line 57, in getTreeFromXml
    tree = ET.fromstring(xml)
  File "/usr/local/lib/python2.6/xml/etree/ElementTree.py", line 964, in XML
    return parser.close()
  File "/usr/local/lib/python2.6/xml/etree/ElementTree.py", line 1254, in close
    self._parser.Parse("", 1) # end of data
ExpatError: no element found: line 1, column 0

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    An unexpected error has occurred.
    Please report the above lines to:
   s3tools-bugs@lists.sourceforge.net
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

--
Gea-Suan Lin (02-25007358 #2807, FAX: 02-25090058)
PIXNET Digital Media Corporation