which python modules required?

2007-03-04
2013-02-19
  • Nobody/Anonymous

    What are the additional python modules required for the s3cmd to work?  Plain install of python2.4 on debian is not working.

    Thanks.

    Dan

     
    • Michal Ludvig

      Michal Ludvig - 2007-03-04

      On Debian Etch it s3cmd-0.9.1 needs python-elementtree.
      Further versions may require python-crypto and python-magic, we'll see.

       
    • Nobody/Anonymous

      It is working ok now.  I still had trouble after installing elementtree, but that's because python was still running 2.2 by default (debian sarge).  When I explicitly called /usr/bin/python2.4 with s3cmd, it works fine.

      Now I need to get it working on a virtual private server running fedora1.  It also is on python 2.2, but I have no handy apt-get to help me with the installation this time.

      Thanks

      Dan

       
    • Nobody/Anonymous

      built python 2.4 from source, installed it and then loaded elementree -- it works! (python2.4 installation overwrote the 2.2 here.  Hopefully that doesn't come back to bite me somewhere else.) 

      Dan

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks