probs with 0.9.8-rc1 (?)

  • Nobody/Anonymous


    I couldn't get 0.9.7 to install on Ubuntu due to the syntax error problem so I tried 0.9.8-rc1. That one installs correctly. I config'd it and it tested the keys successfully.

    However I get SignatureDoesNotMatch when I try to create a bucket, list the contents of the bucket, or upload a file, just about anything basically. The only time it works is if I do 's3cmd ls'. That's it. I tried generating a new key and pasted that into the config but it didn't change anything.

    I also tried changing a character in my secret key. This causes ls to fail. With the correct key ls works. This proves to me that the key is correctly entered into the config.

    So I have no idea how to fix this. Any ideas??


    • Michal Ludvig

      Michal Ludvig - 2008-06-16

      Is there something special in the bucket name? Some non-us-ascii characters perhaps? Can you create a bucket with ascii-only character and numbers? Does that work? If it helps tell me what bucket name caused the problem, if it doesn't post the output of the failing command with --debug. Thanks

    • Nobody/Anonymous


      There was nothing special in the bucket name. But I followed your advice and tried a bunch of different names.

      Here's what I found: it works fine as long as it's lower case. As soon as you have a capital letter in the bucket name it fails (403 forbidden / sig does not match).

      Hope that helps.

      As for me I'll be fine using all lower-caps for now.

      Thanks for writing this app. Take care,


      • Michal Ludvig

        Michal Ludvig - 2008-11-11

        JFYI Access to upper case named buckets has been restored in s3cmd


Log in to post a comment.