Christian - 2011-08-19

Hi everyone

I tried to look for a topic about this but couldn't find any. Sorry if it has already been discussed.

I noticed something odd : depending on the use or not of -no-progress, I have quite a different result in term of transfer speed.
For instance, the upload of a 2GB file :

# s3cmd put 2GBfile s3://test/
2GBfile -> s3://test/2GBfile 
2147479552 of 2147479552   100% in  220s     9.28 MB/s  done

# s3cmd -no-progress put 2GBfile s3://test/
File '2GBfile' stored as 's3://test/2GBfile' (2147479552 bytes in 28.9 seconds, 70.96 MB/s)

Same thing with download :

# s3cmd get s3://test/2GBfile
s3://test/2GBfile -> ./2GBfile 
2147479552 of 2147479552   100% in  221s     9.26 MB/s  done

# s3cmd -no-progress get s3://test/2GBfile
File s3://test/2GBfile saved as './2GBfile' (2147479552 bytes in 19.1 seconds, 107.15 MB/s)

Those are the latest tests I ran but I got similar results everytime.
I'm using s3cmd with a Scality cloud (S3 like). Do any of you guys noticed this behavior ?
Any idea how -progress (activated by default) works ?

Christian