#40 NameError: global name 'real_filename' is not defined

Malfunction
closed-fixed
nobody
s3cmd (119)
5
2015-02-09
2009-10-19
Rik Harris
No

When repeated failures to upload occurs, there is an attempt to log the error message "Upload of '%s' failed too many times. Skipping that file.", the error logging itself fails with the error "NameError: global name 'real_filename' is not defined".

This is in a script, which usually works, but it looks like some network error was occurring at the time.

See log:
------------------------------------------------------
WARNING: Retrying failed request: /kodak19/100_1914.JPG ((-2, 'Name or service not known'))
WARNING: Waiting 3 sec...
WARNING: Retrying failed request: /kodak19/100_1914.JPG ((-2, 'Name or service not known'))
WARNING: Waiting 6 sec...
WARNING: Retrying failed request: /kodak19/100_1914.JPG ((-2, 'Name or service not known'))
WARNING: Waiting 9 sec...
WARNING: Retrying failed request: /kodak19/100_1914.JPG ((-2, 'Name or service not known'))
WARNING: Waiting 12 sec...
WARNING: Retrying failed request: /kodak19/100_1914.JPG ((-2, 'Name or service not known'))
WARNING: Waiting 15 sec...

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
An unexpected error has occurred.
Please report the following lines to:
s3tools-bugs@lists.sourceforge.net
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Problem: NameError: global name 'real_filename' is not defined
S3cmd: 0.9.9
Python: 2.5.2 (r252:60911, Sep 11 2008, 13:43:31) [GCC 4.2.4]

Traceback (most recent call last):
File "/usr/bin/s3cmd", line 1562, in <module>
main()
File "/usr/bin/s3cmd", line 1542, in main
cmd_func(args)
File "/usr/bin/s3cmd", line 337, in cmd_object_put
error(u"Upload of '%s' failed too many times. Skipping that file." % real_filename)
NameError: global name 'real_filename' is not defined

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
An unexpected error has occurred.
Please report the above lines to:
s3tools-bugs@lists.sourceforge.net
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Discussion

  • Michal Ludvig

    Michal Ludvig - 2009-10-19

    Hi,
    this has already been fixed in 0.9.9.91. Please upgrade.

    Michal

     
  • Michal Ludvig

    Michal Ludvig - 2009-10-19
    • status: open --> closed-fixed
     
  • Rik Harris

    Rik Harris - 2009-10-19

    Thanks for the lightning response. I actually checked "Latest News" on http://s3tools.org/s3tools to make sure I had the latest version before logging the bug, but should have looked at the code repository.

     
  • Rik Harris

    Rik Harris - 2009-10-19
    • status: closed-fixed --> open-fixed
     
  • Matt Domsch

    Matt Domsch - 2015-02-09
    • status: open-fixed --> closed-fixed
     

Log in to post a comment.