#6 Cygwin poppler Win32 patch

closed-fixed
nobody
None
5
2008-03-20
2007-12-03
No

This patch fixes building the poppler module from SVN (r2706) on Cygwin/MinGW/MSWin32.

The have_func() call has to be moved up because the ruby module deps haven't been built yet, so the linker complains that "cannot find -lruby-..." and produces a false negative.

The poppler module also explicitly depends on gtk.

Discussion

  • Kouhei Sutou

    Kouhei Sutou - 2008-03-20

    Logged In: YES
    user_id=1012232
    Originator: NO

    I'm sorry for my late response.
    I've committed the changes in trunk.

    I think Ruby/Poppler depends on Ruby/GdkPixbuf not Ruby/GTK+.

     
  • Kouhei Sutou

    Kouhei Sutou - 2008-03-20
    • status: open --> closed-fixed
     
  • Yaakov Selkowitz

    Logged In: YES
    user_id=677371
    Originator: YES

    > I think Ruby/Poppler depends on Ruby/GdkPixbuf not Ruby/GTK+.

    poppler.so calls gdk_region_get_type from gtk2.so.

     
  • Kouhei Sutou

    Kouhei Sutou - 2008-03-20

    Logged In: YES
    user_id=1012232
    Originator: NO

    OK. I've added Ruby/GTK+ dependency too.
    Thanks.

     

Log in to post a comment.