Hi,

> I can confirm that the problem is related to the GRClosure, because I reverted
> the
> files to the revisions prior to the GRClosure changes and now I have
> Ruby-GNOME2
> from the CVS working like a charm for my applications.

I fixed the problem. But this fix isn't complete. Some
problems are sure to remain.

Could you try HEAD again? I can fix the problem if you find
a script which produces the problem. :-)
If you use GC.start, you can find the problem easily.

That's cool, Kouhei. :-)

If you want to send your Ruby-GNOME2 with the fixes directly
to me I will test it as soon as possible. If not, I will wait for the fix
to show up in the anonymous CVS and I will test it, surely.

Thanks!!

Cheers,
Joao