(sorry if this is a duplicate message.. sent before with no subject)

I tried compiling the latest ruby-gnome2 code last night but I ran into problems with the gtk3 build.  I'm on Fedora 15 (gtk3-devel-3.0.12-1.fc15), but this version of gtk3 doesn't have the font chooser dialog stuff in it.

compiling rbgtkfontchooserdialog.c
rbgtkfontchooserdialog.c: In function ‘rg_initialize’:
rbgtkfontchooserdialog.c:39:5: warning: implicit declaration of function ‘gtk_font_chooser_dialog_new’ [-Wimplicit-function-declaration]
rbgtkfontchooserdialog.c:39:5: warning: nested extern declaration of ‘gtk_font_chooser_dialog_new’ [-Wnested-externs]
rbgtkfontchooserdialog.c:39:12: warning: assignment makes pointer from integer without a cast [enabled by default]
rbgtkfontchooserdialog.c: In function ‘Init_gtk_fontchooserdialog’:
rbgtkfontchooserdialog.c:48:33: error: ‘GTK_TYPE_FONT_CHOOSER_DIALOG’ undeclared (first use in this function)
rbgtkfontchooserdialog.c:48:33: note: each undeclared identifier is reported only once for each function it appears in
make[2]: *** [rbgtkfontchooserdialog.o] Error 1


Is this something we can enable/disable based on the version of GTK3 that is installed?  Or do I need to upgrade my system to be able to use the new stuff?

Jon