sorry, i guess it'll be a gentoo specific bug of the package rubygems.


On 08/04/2010 08:27 AM, Dobai-Pataky Bálint wrote:
hi,

* subversion update start -->
 *      repository: https://ruby-gnome2.svn.sourceforge.net/svnroot/ruby-gnome2/rbbr/trunk
At revision 3782.
 *    working copy: /usr/portage/distfiles/svn-src/rbbr/trunk

>>> Source unpacked in /dev/shm/portage/dev-ruby/rbbr-9999/work
>>> Compiling source in /dev/shm/portage/dev-ruby/rbbr-9999/work/rbbr-9999 ...
/usr/lib64/ruby/site_ruby/1.8/rubygems/defaults/operating_system.rb:25:in `ruby_engine': uninitialized constant Module::RUBY_DESCRIPTION (NameError)
    from /usr/lib64/ruby/site_ruby/1.8/rubygems/defaults.rb:36:in `user_dir'
    from /usr/lib64/ruby/site_ruby/1.8/rubygems/defaults/operating_system.rb:15:in `default_path'
    from /usr/lib64/ruby/site_ruby/1.8/rubygems.rb:635:in `path'
    from /usr/lib64/ruby/site_ruby/1.8/rubygems/source_index.rb:68:in `installed_spec_directories'
    from /usr/lib64/ruby/site_ruby/1.8/rubygems/source_index.rb:58:in `from_installed_gems'
    from /usr/lib64/ruby/site_ruby/1.8/rubygems.rb:883:in `source_index'
    from /usr/lib64/ruby/site_ruby/1.8/rubygems/gem_path_searcher.rb:81:in `init_gemspecs'
    from /usr/lib64/ruby/site_ruby/1.8/rubygems/gem_path_searcher.rb:13:in `initialize'
    from /usr/lib64/ruby/site_ruby/1.8/rubygems.rb:841:in `new'
    from /usr/lib64/ruby/site_ruby/1.8/rubygems.rb:841:in `searcher'
    from /usr/lib64/ruby/site_ruby/1.8/rubygems.rb:840:in `synchronize'
    from /usr/lib64/ruby/site_ruby/1.8/rubygems.rb:840:in `searcher'
    from /usr/lib64/ruby/site_ruby/1.8/rubygems.rb:479:in `find_files'
    from /usr/lib64/ruby/site_ruby/1.8/rubygems.rb:983:in `load_plugins'
    from /usr/lib64/ruby/site_ruby/1.8/rubygems.rb:1139
    from /usr/lib64/ruby/site_ruby/1.8/auto_gem.rb:5:in `require'
    from /usr/lib64/ruby/site_ruby/1.8/auto_gem.rb:5
 * ERROR: dev-ruby/rbbr-9999 failed:
 *   install.rb config failed

ruby -v
ruby 1.8.6 (2010-01-11 patchlevel 388) [x86_64-linux]

anyone seen this?
thanks in advice
-- 
Dobai-Pataky Balint
------------------------------------------------------------------------------ The Palm PDK Hot Apps Program offers developers who use the Plug-In Development Kit to bring their C/C++ apps to Palm for a share of $1 Million in cash or HP Products. Visit us here for more details: http://p.sf.net/sfu/dev2dev-palm
_______________________________________________ ruby-gnome2-devel-en mailing list ruby-gnome2-devel-en@lists.sourceforge.net https://lists.sourceforge.net/lists/listinfo/ruby-gnome2-devel-en

-- 
Dobai-Pataky Balint