#183 Unable to package ruby-gnome2 for ruby 2.0 on Arch Linux. Error: expected '(' before '!' token

0.2
open
nobody
None
5
2013-03-07
2013-03-07
A R
No

Hi,

I'm on 64-bit Arch Linux.
ruby 2.0.0_p0
ruby-pkgconfig 1.1.4

I'm trying to package ruby-atk, ruby-gdkpixbuf2, ruby-gio2, ruby-glib2, ruby-gtk2 and ruby-pango.

Here is the PKGBUILD I'm currently using: http://ix.io/4E0

Here is the full output: http://ix.io/4DZ

The errors:

rbgdkscreen.c: In function 'rg_get_setting':
rbgdkscreen.c:213:8: error: expected '(' before '!' token
rbgdkscreen.c:214:9: error: expected ';' before 'gtype'

Thanks.

Best regards,
Alexander Rødseth

Discussion

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks