Don`t work with b standart

  • andris

    andris - 2008-02-18

    Pleas help me, when i run Wive-0.6.1 in AP mode can`t connect from old card who works only in  b standart, with g standart all Ok. Hardware: Edimax BR-6204Wg
    With natiwe software from Edimax working.

    • Schlot

      Schlot - 2008-02-23


      as far as I remember, some values in /etc/network/wifi/general need to be adapted for 802.11b standard. Try these:

      /sbin/iwpriv wlan0 set_mib basicrates=15
      /sbin/iwpriv wlan0 set_mib oprates=4095
      /sbin/iwpriv wlan0 set_mib band=3

      The "band" parameter is a binary mask:
      1: 802.11b
      2: 802.11g
      Therefore, 3 (=1 + 2) means that both standards are supported. Refer to RTL8186 datasheet for details.

      The data rate parameters were at least in rev. 0.6.0 set wrong by default.

      Good luck!



Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks