Permanent Installation?

  • OPaul

    OPaul - 2006-09-18

    How do I permanently install the rtl818x-newstack driver? Right now I have to keep insmod every boot.

    • IvanMajhen

      IvanMajhen - 2006-09-19

      Create folder /lib/modules/{your kernel name}/net and then copy all *.ko files into.
      After that run depmod -a.
      If u wont to autoload drivers then add r8180 to
      /etc/modules.autolad.d/kernel-2.6. This is on GENTOO. Some system may have differen file. Let me know if works.

    • OPaul

      OPaul - 2006-09-19

      I'm using Ubuntu and did the following:

      I made a new folder in /lib/modules/ called "rtl8180" and put the following in;
      ieee80211_crypt_ccmp-rtl.ko ieee80211_crypt_tkip-rtl.ko
      ieee80211_crypt-rtl.ko ieee80211_crypt_wep-rtl.ko

      Then added "r8180" to /etc/modules

      The driver loads fine and I'm able to see all the networks in my area. However, when I try and connect to one, it never connects and my machine becomes unresponsive. The mouse moves around but when I try and start something it won't load. The wireless never connects to a network.

      The following appears in dmesg;
      rtl8180: Setting SW wep key
      rtl8180: Setting SW wep key
      rtl8180: Setting SW wep key
      rtl8180: Setting SW wep key
      rtl8180: Setting SW wep key
      rtl8180: Setting SW wep key
      ieee80211_crypt: registered algorithm 'WEP'
      BUG: unable to handle kernel NULL pointer dereference at virtual address 00000000
      printing eip:
      *pde = 00000000
      Oops: 0000 [#1]
      Modules linked in: ieee80211_crypt_wep ipv6 capability commoncap ppdev speedstep_ich speedstep_lib cpufreq_userspace cpufreq_stats freq_table cpufreq_powersave cpufreq_ondemand cpufreq_conservative video button battery container ac af_packet r8180 ieee80211_rtl ieee80211_crypt_rtl lp pcmcia snd_intel8x0 snd_ac97_codec snd_ac97_bus snd_pcm_oss snd_mixer_oss e100 mii yenta_socket rsrc_nonstatic pcmcia_core snd_pcm snd_timer snd soundcore parport_pc parport snd_page_alloc floppy pcspkr intel_agp agpgart psmouse serio_raw shpchp pci_hotplug evdev usbhid ext3 jbd mbcache ide_generic uhci_hcd usbcore ide_cd cdrom ide_disk piix generic thermal processor fan
      CPU: 0
      EIP: 0060:[<00000000>] Not tainted VLI
      EFLAGS: 00010202 ( #1)
      EIP is at rest_init+0x3feffde0/0x1b
      eax: 00000000 ebx: c99699c0 ecx: c99692c0 edx: d0a56d00
      esi: c849e3b4 edi: c99699d4 ebp: 00000001 esp: cc8a7e10
      ds: 007b es: 007b ss: 0068
      Process wpa_supplicant (pid: 6708, threadinfo=cc8a6000 task=cff70a90)
      Stack: d09c1ae2 d09c3bc4 cc8a7f4c cc8a7f4c c849e260 c849e000 00000000 00200246
      c849e3b4 c01afdc9 048a7f4c 00000000 00000000 00000000 00000000 00000000
      00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
      Call Trace:
      <d09c1ae2> ieee80211_wx_set_encode+0x261/0x4ad [ieee80211_rtl] <c01afdc9> copy_from_user+0x2e/0x64
      <d09e9cec> r8180_wx_set_enc+0x81/0x85 [r8180] <c023010c> ioctl_standard_call+0x143/0x296
      <d09e9c6b> r8180_wx_set_enc+0x0/0x85 [r8180] <c0230744> wireless_process_ioctl+0x340/0x3da
      <d09e9c6b> r8180_wx_set_enc+0x0/0x85 [r8180] <d09e9c6b> r8180_wx_set_enc+0x0/0x85 [r8180]
      <c021ceb5> sock_ioctl+0x0/0x1f0 <c0227b17> dev_ioctl+0x2dc/0x321
      <c01416e6> __handle_mm_fault+0x655/0x8e7 <c015a72e> pipe_writev+0x207/0x4b5
      <c021ceb5> sock_ioctl+0x0/0x1f0 <c015f4d9> do_ioctl+0x19/0x55
      <c015f567> vfs_ioctl+0x52/0x247 <c015f7b9> sys_ioctl+0x5d/0x6c
      <c0102ac3> sysenter_past_esp+0x54/0x75
      Code: Bad EIP value.
      EIP: [<00000000>] rest_init+0x3feffde0/0x1b SS:ESP 0068:cc8a7e10

    • IvanMajhen

      IvanMajhen - 2006-09-19

      Do you have generic ieee80211 stack? You must uninstal it because it doesn't work with rtl. Or download my uploaded drivers and try with them. They are patched for latest 2.6.17 kernel ann gcc.

    • Martin Kelly

      Martin Kelly - 2006-10-29

      Thank you Ivik! I couldn't figure out how the CVS tree worked as far as compilationwent, but I got it now and I'm running a 2.6.17 kernel with wireless thanks to your package :).

    • Wojciech Kazubski

      My system is also a bit confused when I try to install rtl818x driver. It tries to load standard modules from kernel instead of *-rtl ones.
      Is it possible to convert a driver to use standard kernel ieee80211 modules possibly plus some extra add-on module if necessary?

    • IvanMajhen

      IvanMajhen - 2006-11-27

      Try my patched drivers from link above. They dont try to load standard ieee stack from kernel, so u can have both installed.
      Merging generic ieee stack was in plan, but as u can see this project is dead. My kernel programming skills r not that good. This project needs new maintainer. Dont know where Andrea is. A very few people r using this wireless card under linux.
      And wpa needs to be rewritten.I newer got it to work, only with ndiswrapper. This driver driver works great for me with wep, no lockups.
      Dont know why realtek doesnt support linux. They have closed source drivers for some old kernel (fedora think) which i cant use because i use udev and different gcc, which is under gentoo very time consuming (compaling gcc). And they dont use standard linux commands for essid, but with private extensions iwpriw, so standard programs for wirelless managing cant be used with it. And wpa is not supported, i think

    • Wojciech Kazubski

      I think, that few people use Realtek card because they can't find a driver.
      Now Realtek has a modified version of Andrea`s GPL driver, it is dated from the end of May and has some additions, as a support for a rtl8255 RF chip. It is a bit odd packed, some tarballs inside big one but builds OK on Fedora Core 6. Changelog was not updated since the last version on SF so I can't tell what was added/modified and by whom. The version number in changelog is still 0.22.
      I have Pentagram HorNET WiFi card with rtl8185+rtl8225 chips and it works for me after I manually load proper modules. I had some problems with configuring WEP but now I foud that NetworkManager can do this well. Probably signal quality reporting does not work.
      I tried also ndiswrapper, but it did not work for me (hangup on modprobe - stack size problem?).

      • jholt

        jholt - 2007-01-03

        just wanted to add that the driver available on realteks sites builds against 2.6.18 without the patches from the forums and looks as though all it needs are the 2.6.19 patches since it still defines config.h it should be good to go

    • IvanMajhen

      IvanMajhen - 2006-11-28

      I've got a belkin 6020 card ver3 with rtl8180 chip. I hate Belkin, because they have 3 cards with the same name and different chips: prism, orinoco and realtek. I found somewhere on internet drivers packed with wpa_supplicant and tought that wpa will work, but no way. I compiled wpa_supplicant, i tought it will maybe work with card or is modified for my card but no luck. On dmesg i saw that is using wpa, but it can't connect. There is a user manual and in it is that uses ipw driver for wpa. If i modprobe ndiswrapper with same settings, but with wext it works great. So something is wrong with wpa, or my router. I tried every possible configurations.
      So at home I'm using 128bit wep, with hidden essid and mac filtering and os driver. I'm sharing net with my friend, and with ndiswrapper is little difficult to connect, it needs about min to connect and signal is very weak and sometimes it disconnects. If i put iwconfig wlan0 rate 1M sens 85, signal is always above 90% with os driver.
      In school I use ndiswrapper for wpa and works perfectly.

    • Wojciech Kazubski

      I am testing your version of r8180/ieee8211_rtl kernel modules. Everything works OK, at least with WEP. All necessary modules are loaded automatically on boot. The only thing I had to do was an addition of one line to r8180_rtl8225.h:

      [fle begin]
      --- rtl8180-latest/r8180_rtl8225.h.fc   2006-12-09 19:30:27.000000000 +0100
      +++ rtl8180-latest/r8180_rtl8225.h      2006-12-09 19:29:58.000000000 +0100
      @@ -24,3 +24,4 @@
      void rtl8225_rf_close(struct net_device *dev);
      void rtl8225_rf_sleep(struct net_device *dev);
      void rtl8225_rf_wakeup(struct net_device *dev);
      +void rtl8180_set_mode(struct net_device *dev,int mode);
      [file end]

      Without this line I got an error during make.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks