Belkin F5D7000 v7 WPA

  • Abandon

    Abandon - 2007-03-20

    I've been trying to get a Belkin wireless card (F5D7000 v7) working.  I tried both current from SVN and the sources from Realtek.  I had to modify both of them by adding the following lines in the pci_device_id structure in r8180_core.c.

            {       /* Belkin F5D7000 v7 */
                    .vendor = PCI_VENDOR_ID_BELKIN,
                    .device = 0x700f,
                    .subvendor = PCI_ANY_ID,
                    .subdevice = PCI_ANY_ID,
                    .driver_data = 2,

    with this added the driver loads recognizes the card and creates wlan0.  A copy of dmesg log, commandline and config files included below.  Overall I was very pleased to have gotten this far after the nasty surprise of finding out Belkin changes chipset more often then I change underwear.  At this point I can start the wpa_supplicant and everything seems fine but access point across the room is never found. wpa_supplicant just always reports scanning.  Any suggestions would be appreciated.

    ieee80211_crypt: registered algorithm 'NULL'
    ieee80211_crypt: registered algorithm 'WEP'
    ieee80211_crypt: registered algorithm 'TKIP'
    ieee80211_crypt: registered algorithm 'CCMP'

    Linux kernel driver for RTL8180 / RTL8185 based WLAN cards
    Copyright (c) 2004-2005, Andrea Merello
    rtl8180: Initializing module
    rtl8180: Wireless extensions version 20
    rtl8180: Initializing proc filesystem
    rtl8180: Configuring chip resources
    ACPI: PCI Interrupt 0000:00:14.0[A] -> Link [LNKB] -> GSI 10 (level, low) -> IRQ 10
    rtl8180: Memory mapped space @ 0xde002000
    rtl8180: MAC controller is a RTL8185 b/g (V. D)
    rtl8180: This is a PCI NIC
    rtl8180: Reported EEPROM chip is a 93c56 (2Kbit)
    rtl8180: Card MAC address is 00:17:3f:2d:55:98
    rtl8180: EEPROM version 105
    rtl8180: Card reports RF frontend Realtek 8225
    rtl8180: WW:This driver has EXPERIMENTAL support for this chipset.
    rtl8180: WW:use it with care and at your own risk and
    rtl8180: Energy threshold: b
    rtl8180: PAPE from CONFIG2: 6
    rtl8180: IRQ 10
    rtl8180: Driver probe completed

    rtl8180: Bringing up iface
    rtl8180: Card successfully reset
    enabling WPA

    WPA_SUPPLICANT commandline
    /sbin/wpa_supplicant -Dipw -c/etc/wpa_supplicant/wpa_supplicant.conf -W -B -iwlan0 -P/var/run/


            pairwise=CCMP TKIP
            group=CCMP TKIP WEP104 WEP40
            psk="a password"

    # Plaintext connection (no WPA, no IEEE 802.1X)

    • tennis2

      tennis2 - 2007-03-21

      Is it just wpa_supplicant that can't find your access point ?

      What happens, if after loading the modules and bringing up the interface with "ifconfig wlan0 up", instead of starting wpa_supplicant you try "iwlist wlan0 scanning" ?

      Does this detect your access point?

    • Abandon

      Abandon - 2007-03-21

      I tried this several times.  Each time a get the results just below.  Based on this I was wondering about the dmesg lines saying that realtek 8225 rf frontend support is experimental.  Have others reported this working?

      localhost ~ # iwlist wlan0 scanning
      wlan0     No scan results

      I also pulled the card and put it in a windows machine located nearby.  It sees and acquires the WPA network I'm trying to connect to without a problem. So the hardware itself is probably fine.

      I also tried a number of other ideas of my own.

      1). I noticed the driver_data element in the pci_device_id structure looked like it should be unique so I renumbered them.  No change.
      2). Tried other setting for ap_scan and scan_ssid without effect.
      3). Ran wpa_supplicant from the commandline with -dd to see what it's seeing.  I didn't understand it all but it seemed it didn't see any networks.  In several of the configurations it kept blacklisting a BSSID of all zeros.  Not sure if that means anything.

      After all this I was wondering if there is some way to get the driver itself to say more about what's going on.  I noticed there are some debug definitions at the top of r8180_core.c that would seem to cause the driver to write information to dmesg during operation.  Are any of these useful?

    • malmrose

      malmrose - 2007-04-02

      I have the same card, and am getting similar results. I found this interesting:

      $ifconfig wlan0
      RX packets:0
      TX packets:332

      The radio seems to be sending, but not receiving.

      • tennis2

        tennis2 - 2007-04-03


        ifconfig only shows data packets received/transmitted over the network interface.

        For an ieee820211 wireless lan you have to use control packets to "associate" before you can receive data packets.

        You need to check /proc/net/rtl8187/wlan0/stats-rx to see if the radio is receiving.

    • Kelvin J. Hill

      Kelvin J. Hill - 2007-05-26

      I am another person who has tried, in vain, to get this F5D7000 (Ver:7000uk) card working on Linux. I have compiled everything on Fedora Core 6, with the latest kernel (2.6.20-1.2948.fc6). I am running on an old P3 x 2 CPU SMP server system.

      After insering the PCI IDs as per the first posting, the card gets recognised and activated with dmesg showing much the same as in the first post. Again, like the fist poster, I get no results from a "iwlist scan", no joy at all from wpa_supplicant and iwconfig shows no traffic etc.

      Basically, this has to be one of the worst purchases I have made recently. Even using ndiswrapper and the commercial "driverload" software, the card is unusable. Both ndiswrapper and driverload cause kernel panics or lockups. "ndiswrapper" fails with the old "attempt to schedule while atomic" bug. This is with both the Realtek and Belkin ndis drivers.

      Does ANYONE have any ideas how to activate the radio portion of this card? Could Belkin have deliberately crippled it to prevent 3rd part drivers based on the Realtek reference design from working?



    • loziniak

      loziniak - 2007-07-15

      I have the same problem with a no-name card sold in Poland. Mine is called "LogiLink wireless lan cardbus", and FCC ID is NDD9573060509.
      see thread:
      Maybe the developers of this project or another talented programmer could fix this bug if we did some testing?


      • Olaf

        Olaf - 2007-09-27

        I think there is a new rtl8185 Chiprev or a bug in the RF Chip detection since many newer cards refuse to work.
        With my Allnet ALL0261R PCI Card or Longshine LCS-8531G3 PC-Card rtl8180.ko load without error but no rx/tx...

        • Robert Krawczyk

          Robert Krawczyk - 2008-10-10


          Same here: I have a LevelOne WPC 0301 cardbus card. The FCC ID is NHPWLG1104B, EEPROM 93c56, RF 8225. It is reported with a PCI ID of 10ec:8185 (rev 20). Seemingly the chip is a 8185. I compiled the module -- this worked without any problems. After loading the module everything is fine, *but* iwscan finds no networks and no connection to an access point is possible.
          What can I do to help?

    • demoz

      demoz - 2007-09-21

      Just to bump this issue back up...

      I have the same card (Belkin F5D7000 Rev 7) and have had absolutely zero success with it - tried ndiswrapper with realtek and belkin drivers, and was hoping the rtl-wifi driver would be the solution I was looking for, but it isn't.

      I seem to be having the same problem as the others here - everything build's fine, modules install ok, even setting connection settings with iwconfig appears to be ok - but still no connection.

      It certainly seems like the radio segment of this card (realtek 8225?) if off.

      Willing to help any way I can - but I'm no driver developer I'm afraid.  Would be nice if this issue could be given some attention by the developers though.


      (Ubuntu Server 7.0.4 - Kernel version 2.6.20-15-server)

    • Wojciech Kazubski

      What is the FCC number of your Belkin card?
      Did you tried to contact Belkin?


    • demoz

      demoz - 2007-09-21

      The FCC ID is: K75F5D7000F

      I haven't tried contacting Belkin because, to be honest, I doubt that they would help much.  Linux isn't listed on the box as a supported operating system (is it on many wireless cards?), and the driver disk doesn't come with linux drivers do I doubt they'd be willing (able?) to offer much support to me.  Isn't that the point of these kind of projects - to provide the linux support where it doesn't exist from the manufacturers?

      Who knows, maybe i'll give them a go anyway...  Still, any kind of help from the community would be greatly appreciated and of course getting this driver to work with this fairly popular device would only increase the driver's kudos :-)


    • fortytruth

      fortytruth - 2009-04-12

      Hello everybody, i have the same problem with a Trendnet PCMCIA card, the "TEW-421PC", chipset "RTL-8185". The card is working fine with ndiswrapper, and with this free driver, dmesg says the module loads properly (with 'insmod rtl818x-newstack/r8180.ko') but iwlist wlan0 scan gives no results, even if i enter essid, key, and acces-point with iwconfig...

      I hope this problem will be fixed soon, i hate using ndiswrapper shit ^^ Good luck to devs, contact if you want more informations.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks