lenny and RTL8187B

  • luca_p

    luca_p - 2009-06-19

    Hi all. I'm going crazy to make my Toshiba laptop wifi card working.
    Before to start explaining my problem I want to tell you that I am a newbie in wireless on linux and in linux in general... :)

    I'm following the guide at the http://rtl-wifi.sourceforge.net/wiki/Installing url. All goes well since here

    # insmod ieee80211/ieee80211-rtl.ko
    insmod: error inserting 'ieee80211/ieee80211-rtl.ko': -1 Invalid module format

    dmesg says:
    [  189.265781] r8187: Unknown symbol ieee80211_softmac_start_protocol
    [  189.265781] r8187: Unknown symbol ieee80211_wx_get_freq
    [  332.411361] usbcore: registered new interface driver rtl8187
    [  356.902998] usbcore: deregistering interface driver rtl8187
    [  616.700344] ieee80211_crypt: unregistered algorithm 'NULL'
    [  669.424442] ieee80211_crypt: registered algorithm 'NULL'
    [  677.676312] ieee80211_crypt: registered algorithm 'WEP'
    [  681.988176] ieee80211_crypt: registered algorithm 'TKIP'
    [  685.566804] ieee80211_crypt: registered algorithm 'CCMP'
    [  689.415188] ieee80211_rtl: exports duplicate symbol ieee80211_stop_queue (owned by mac80211)

    What does it means?

    Here is the output of the lsusb:
    Bus 001 Device 002: ID 0bda:8197 Realtek Semiconductor Corp. RTL8187B Wireless Adapter

    I found this thread https://sourceforge.net/forum/forum.php?thread_id=1706437&forum_id=652149 that seems to be my same problem, but the solution of installing drivers by ivik for RTL8185 doesn't work...

    At the end of the thread I see that awr solved his problem, but for kernel 2.6.20, but I I work on Debian Lenny 2.6.26-2-686. Could work even for me?

    Thanks for your help...



    • Pontabo

      Pontabo - 2009-06-19

      I've got the same problem with my toshiba.  I'm running Debian lenny amd64.  Something changed between kernel revisions 2.6.24 and 2.6.26 (at least the Debian version of the kernel) that doesn't allow the rtl8187b driver to be inserted into the kernel.  I imagine it has something to do with how the rtl8187b modules export their symbols.  Anyway, the way I worked around this problem was to use an older kernel from Debian etch.  2.6.24-etchnhalf.1, to be exact (this was the only etch kernel that supported my sound card at the time).  The rtl8187b drivers build and insert into this kernel with no problems.  Some of lenny's functionality isn't supported by the 2.6.24 kernel, though.  In particular, my system won't resume the session I went into hibernation from until I boot from the 2.6.26 kernel (really freaked me out when I accidentally boote .26 and it restored a session I had hibernated weeks before.)  I don't really use the lost functionality anyway, so it's not much of an issue to me.  If you choose to go that route, just make sure that you get the appropriate kernel, headers, and any other modules you need.  Also, all the user-built modules you are using will have to be rebuilt.

      I'm waiting for Debian to release a 2.6.27 or 2.6.28 kernel before I update, as wifi support for rtl8187b is supposed to be supported in the kernel tree as of 2.6.27.

      Hope this helps.


Log in to post a comment.