rtl8187se wpa2 aircrack-ng

rtl-wifi
Rick
2009-02-15
2013-05-02
  • Rick

    Rick - 2009-02-15

    Hi guys, before anything i wanna tank you for the great job in this project! It`s just awesome and i`m just surfing now because of this drive =) Tks guys!

    Guys my system is one Slackware 12.1. My notebook is one Gateway M-1629(I really like it) and my router is Linksys WRT110.

    Today i`m just surfing in my WRT110 configuration menu and i had found some weird logs about connection outside my home (neighbor?). Them i changed my router security to WPA2 with AES but after 4 out 5 hours trying to configure my wpa_supplicant.conf for my card rtl8187SE to work with WPA2 AES i had failed. I really tried the docs and search in the internet but all the tutorials didn`t work...
    My final configuration is like this:

    network={
             ssid="home"
             proto=RSN WPA
             key_mgmt=WPA-PSK
             pairwise=CCMP TKIP
             psk="00000000000000000000000000002345"
           }

    And i tried alot of different configuration to do the WPA2 work but i couldn`t

    Until this moment my drive is rtl8187se_linux_26.1023.0928.2008 and i tried to change to another version older than this one, but the problem still there. I  cannot connect to mine wrt110 router with wpa2...   =/
    In my system logs syslog,messages our dmesg the messages dosen`t like  weird because they don`t show any strange massage our exception about the drive our kernel, it`s just show messages like "link up" "Network not read" things like that...
    And one more thing guys, i tried to scan my network and attack my network to  see if it`s to easy our if it`s ok and more one time i had some problems with the driver, because the  aircrack-ng-1.0-rc2 didn`t work...
    I tried to find a patch but the aircrack-ng dosen`t have for "SE" just for the rtl8187
    here is the link http://patches.aircrack-ng.org/

    Guys tank you very much and i`m sorry for the long post hehe
    I will wait for any advice our reply.

    Regards 

     
    • ilker Aktuna

      ilker Aktuna - 2009-03-24

      Hi,

      Can you please retry using WPA2 setting the hardware operation mode of your WRT110 router to 802.11B ?
      I assume you are now using 802.11G or 802.11B/G on the router.
      Please test with 802.11B and let us know.
      Because, I noticed a similar issue ussing WPA2  and 802.11G.

      Thanks,
      ilker

       
  • Anonymous - 2009-10-25

    Hi,
    I have the same problem. I tried WEP, WPA, WPA2 and no encryption, always the same problem.
    On windows and OS X i don't have any problems.

    0bda:8189 Realtek Semiconductor Corp. RTL8187B Wireless 802.11g 54Mbps Network Adapter

    Linux THC 2.6.31-ARCH #1 SMP PREEMPT Fri Oct 23 10:03:24 CEST 2009 x86_64 Intel(R) Core(TM)2 Duo CPU E8400 @ 3.00GHz GenuineIntel GNU/Linux

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks