#14 Feature request: write list of changed files.

closed-fixed
nobody
Interface (4)
5
2008-05-23
2008-02-20
No

For large trees (which mine is), it would simplify the rsync I run after rsyncrypto *greatly* if rsyncrypto wrote to a file the names of the files it changed (that is, the destination files) taking into account name encryption and so on. Then I could just use that file list with rsync's --files-from option, and save myself walking the whole tree again (which takes more than an hour alone!).

-Robin

Discussion

  • Shachar Shemesh

    Shachar Shemesh - 2008-05-07

    Logged In: YES
    user_id=411662
    Originator: NO

    That should be fairly easy to do with rsync as it is right now. Just run it with the right number of -v, and then use sed to format the output in whatever way you want.

    Unless you see some problem with this, I'm going to close the bug as "rejected".

    Shachar

     
  • Shachar Shemesh

    Shachar Shemesh - 2008-05-08
    • status: open --> closed-rejected
     
  • Robin Powell

    Robin Powell - 2008-05-08

    Logged In: YES
    user_id=85540
    Originator: YES

    I'm sorry I was slow on this.

    Running rsync doesn't help me; let me explain in more detail.

    I have a tree, A, with (say) a million files in it.

    Every day, on the order of 10K files change.

    I use rsyncrypto to sync A to B, with encrypted file names.

    I then sync B out to a remote machine.

    The problem is that there are a million files in B, only 10K have changed, and I have no idea which ones.

    So, I need rsyncrypto to print out the *destination* file names it touched; that is, the file names in the encrypted file name tree.

    -Robin

     
  • Robin Powell

    Robin Powell - 2008-05-08
    • status: closed-rejected --> open
     
  • Shachar Shemesh

    Shachar Shemesh - 2008-05-08

    Logged In: YES
    user_id=411662
    Originator: NO

    Sorry, I mistyped. I meant to say "That should be fairly easy to do with rsyncrypto as it is right now." The rest of the message remains the same.

    If that is still not clear, please let's take the discussion over this to the mailing list. It is the more appropriate forum for this. If the conclusion is that this is a viable feature request, we'll reopen this request.

    Shachar

     
  • Shachar Shemesh

    Shachar Shemesh - 2008-05-23

    Logged In: YES
    user_id=411662
    Originator: NO

    "--files-from" will choke on files deleted by rsyncrypto. Use --include-from instead.

     
  • Shachar Shemesh

    Shachar Shemesh - 2008-05-23
    • status: open --> closed-fixed
     
  • Shachar Shemesh

    Shachar Shemesh - 2008-05-23

    Logged In: YES
    user_id=411662
    Originator: NO

    This problem is now resolved in SVN, and will be available in the next version of rsyncrypto.

    Thank you for reporting this problem.
    Shachar

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks