How to do "Open Run Dialog"?

Developers
Waquesseix
2012-10-25
2013-03-17
  • Waquesseix

    Waquesseix - 2012-10-25

    Hi.
    I'm trying to build RSSOwl. I downloaded the source code from the Git repository and imported it into Eclipse 3.4.2.
    According to this page http://wiki.rssowl.org/index.php/Build_RSSOwl_2.0, the next step is to do "Open Run Dialog", but I cannot find the menu. Would someone tell me how I should do?

     
  • Waquesseix

    Waquesseix - 2012-10-25

    Eclipse screen shot

     
  • genodeftest

    genodeftest - 2012-10-25

    It should be "Run Configurations"

     
  • Waquesseix

    Waquesseix - 2012-10-29

    Thanks for your reply.
    I tried several things and found that clicking build.xml and ant build is the way to build RSSOwl. But Eclipse generated some errors. I tried to solve them, but ANT didn't show distinct reasons.
    Does someone have a hint?

     
  • Waquesseix

    Waquesseix - 2012-10-29

    This is the build log.
    And "build.xml:116: Java returned: 13" is here.

    <java classname="org.eclipse.equinox.launcher.Main" fork="true" failonerror="true" errorproperty="build.stderr">

    ----- build log -----

    Buildfile: C:\Users\dev\workspace\rssowl-RSSOwl-e2ca9c7\org.rssowl.build\build.xml
    [taskdef] Could not load definitions from resource net/sf/antcontrib/antcontrib.properties. It could not be found.
    main:
    [taskdef] Could not load definitions from resource net/sf/antcontrib/antcontrib.properties. It could not be found.
    -properties:
    -clean:
    [echo] Cleaning directory C:/Users/dev/workspace/rssowl-RSSOwl-e2ca9c7/buildDir
    [delete] Deleting directory C:\Users\dev\workspace\rssowl-RSSOwl-e2ca9c7\buildDir
    [mkdir] Created dir: C:\Users\dev\workspace\rssowl-RSSOwl-e2ca9c7\buildDir
    -prepare.build.host:
    [taskdef] Could not load definitions from resource net/sf/antcontrib/antcontrib.properties. It could not be found.
    unpack.eclipse:
    [taskdef] Could not load definitions from resource net/sf/antcontrib/antcontrib.properties. It could not be found.
    -unpack.eclipse.ifnecessary:
    -build:
    [taskdef] Could not load definitions from resource net/sf/antcontrib/antcontrib.properties. It could not be found.
    -build.internal:
    [java] Buildfile: C:/Tools/eclipse3.4.2sdk/plugins/org.eclipse.pde.build_3.4.1.R34x_v20081217/scripts/build.xml
    [java] main:
    [java] preBuild:
    [java] preSetup:
    [java] checkLocalMaps:
    [java] getMapFiles:
    [java] [cvs] cvs checkout: CVSROOT "${mapsRepo}" must be an absolute pathname
    [java] [cvs] cvs [checkout aborted]: Bad CVSROOT.
    [java] [concat] No existing resources and no nested text, doing nothing
    [java] postSetup:
    [java] checkLocalBase:
    [java] getBaseComponents:

    BUILD FAILED
    C:\Users\dev\workspace\rssowl-RSSOwl-e2ca9c7\org.rssowl.build\build.xml:183: The following error occurred while executing this line:
    C:\Users\dev\workspace\rssowl-RSSOwl-e2ca9c7\org.rssowl.build\build.xml:81: The following error occurred while executing this line:
    C:\Users\dev\workspace\rssowl-RSSOwl-e2ca9c7\org.rssowl.build\build.xml:116: Java returned: 13

    Total time: 1 second

     
  • genodeftest

    genodeftest - 2012-10-29

    Hi
    can you please attach the log as a file since Sourceforge forum software removes some parts of it (e.g. backslash).

    Can you try using https://github.com/rssowl/RSSOwl with git instead of CVS? Or correct the CVS error?

     
  • spixycat

    spixycat - 2012-10-30

    @Waquesseix

    I added all (I am a bit lazy ... ;)) all jars in the Eclipse plugin directory to all of the projects that didn't compile, that helps a lot, than

    you need to download db4o project and add it's jar to the build path of rssowl.db4o project

    rssowl.core needs to include rssowl.lib.db4o and rssowl.lib.luchence which are other projects so you can simply add them as ?external? projects

    please do a Project->Clean so that the whole project gets rebuild, than you will fix 99% of the compile errors.

    @genodeftest
    How do you go from "Run Configurations"?

    It should find a main()? Is it an Applet? please help with this very last step! Thanks because it now compiles without any errors (I closed the coretest for now) so I am very close to run it inside Eclipse I think.

    Regards

     
  • genodeftest

    genodeftest - 2012-10-30

    You need to run RSSOwl as Eclipse RCP Application. To do so you need to have the Eclipse RCP package installed. It is neither an applet nor a "normal" application.

     
  • spixycat

    spixycat - 2012-10-30

    it would be very nice to have a step by step instructions on how to run RSSOwl using RCP, the current build page does not even mention usage RCP.

    The threshold is quite high if you have to go through these hops when you want to start using and understanding this software when you are a green-horn and start from scratch.

     
  • genodeftest

    genodeftest - 2012-10-31

    Sorry, I don't know how to do that. I never built RCP applications. I'll ask benjamin pasero to update the Howto.

     
  • spixycat

    spixycat - 2012-11-01

    what is needed I think is a complete description on how to download all the specific components including version numbers etc etc and a description of the changes that you need to do yourself/by hand.

    From what I understand is that you need i.e. a specific Eclipse with RCP and you may have to custom download db4o libraries.

    The end result would be a RSSOwl that compiles and can be debug-ed within a (I guess older) Eclipse version. That is the minimum objective so that developers can "play" with the code. Right now only a few developers are able to work with the code: this is I guess not in the spirit of being an Open Source project?

    I don't mind being the guinea pig to test/verify these description/howto.

     
  • genodeftest

    genodeftest - 2012-11-02

    No answer from bpasero so far…

     
  • spixycat

    spixycat - 2012-11-08

    that is really really to bad because that means that I can really only go through the code: that is it. I have tried to use different Eclipse versions and none would compile, there are a few specific jar versiion of I think older code that has never chamged.

    Sorry but this is I think not in the spirit of an open source a projects that can't be recompiled with designated eclipse version + list of specific jar versions

    Really too bad :(

     
  • spixycat

    spixycat - 2013-01-28

    Dear genodeftest : where can I find/download the "Eclipse RCP package installed" ???

     
  • genodeftest

    genodeftest - 2013-01-28

    Hi
    Do you mean the Eclipse RCP? You can get it from http://www.eclipse.org/downloads/ , choose "Eclipse for RCP and …" or install it from your current Installation of Eclipse via Eclipse Marketplace (to be found in menu "Help"). Is that what you are searching for?

     
  • Waquesseix

    Waquesseix - 2013-02-18

    I installed Eclipse RCP.
    http://www.eclipse.org/downloads/packages/eclipse-rcpplug-developers/ganymedesr2

    And now I'm trying "Run->Run Configurations". But I don't know how to run, so now I'm researching on the Internet.

     
    • WizardCXY

      WizardCXY - 2013-03-17

      Do you have the solution to build the rssowl now? I am encounting the same problem.

       
  • Anonymous - 2013-03-17

    I will revisit the wiki and update it, stay tuned.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks