help! about bulid RSS Owl by eclipse accoring u guys kindly guide!

Developers
solocheng
2013-04-23
2013-06-06
  • solocheng

    solocheng - 2013-04-23

    hi guys

    i bulid RSS owl using Eclipse according your guide following the url:https://github.com/bpasero/rssowl-target/blob/master/README.md but i can not build successfully according your description
    i uncheck all plugins from the "Target Platform" and click on "Add required plug-ins" . but the "Add required plug-ins" never does work.so i select all plug-ins than when i run the RSS owl ,i always got the error info:
    java.lang.RuntimeException: Application "org.eclipse.ui.ide.workbench" could not be found in the registry. The applications available are: org.eclipse.equinox.app.error, org.eclipse.update.core.standaloneUpdate, org.eclipse.update.core.siteOptimizer.
    at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:242)
    at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:386)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:549)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1236)
    at org.eclipse.equinox.launcher.Main.main(Main.java:1212)
    !ENTRY org.eclipse.osgi 2 0 2013-04-23 18:06:27.285
    !MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
    !SUBENTRY 1 org.eclipse.osgi 2 0 2013-04-23 18:06:27.285
    !MESSAGE Bundle reference:file:/E:/junorcp/target_win/plugins/org.eclipse.jdt.junit4.runtime_1.0.200.v20080603-2000.jar was not resolved.
    !SUBENTRY 2 org.eclipse.jdt.junit4.runtime 2 0 2013-04-23 18:06:27.285
    !MESSAGE Missing required bundle org.eclipse.jdt.junit.runtime_[3.3.0,4.0.0).
    !SUBENTRY 1 org.eclipse.osgi 2 0 2013-04-23 18:06:27.286
    !MESSAGE Bundle reference:file:/E:/junorcp/target_win/plugins/org.eclipse.ui.win32_3.2.100.v20080408-0800.jar was not resolved.
    !SUBENTRY 2 org.eclipse.ui.win32 2 0 2013-04-23 18:06:27.286
    !MESSAGE Missing host org.eclipse.ui.ide_[3.2.0,4.0.0).
    !SUBENTRY 1 org.eclipse.osgi 2 0 2013-04-23 18:06:27.286
    !MESSAGE Bundle reference:file:/E:/junorcp/target_win/plugins/org.eclipse.core.filesystem.solaris.sparc_1.0.100.v20080604-1400.jar was not resolved.
    !SUBENTRY 2 org.eclipse.core.filesystem.solaris.sparc 2 0 2013-04-23 18:06:27.286
    !MESSAGE Missing host org.eclipse.core.filesystem_[1.1.0,2.0.0).
    !SUBENTRY 1 org.eclipse.osgi 2 0 2013-04-23 18:06:27.286
    !MESSAGE Bundle reference:file:/E:/junorcp/target_win/plugins/org.eclipse.core.filesystem.linux.x86_1.2.0.v20080604-1400.jar was not resolved.
    !SUBENTRY 2 org.eclipse.core.filesystem.linux.x86 2 0 2013-04-23 18:06:27.286
    !MESSAGE Missing host org.eclipse.core.filesystem_[1.1.0,2.0.0).
    !SUBENTRY 1 org.eclipse.osgi 2 0 2013-04-23 18:06:27.286
    !MESSAGE Bundle reference:file:/E:/junorcp/target_win/plugins/org.eclipse.jdt.launching.macosx_3.1.100.v20080422.jar was not resolved.
    !SUBENTRY 2 org.eclipse.jdt.launching.macosx 2 0 2013-04-23 18:06:27.286
    !MESSAGE Missing required bundle org.eclipse.jdt.debug_0.0.0.
    !SUBENTRY 2 org.eclipse.jdt.launching.macosx 2 0 2013-04-23 18:06:27.286
    !MESSAGE Missing required bundle org.eclipse.jdt.ui_0.0.0.
    !SUBENTRY 2 org.eclipse.jdt.launching.macosx 2 0 2013-04-23 18:06:27.286
    !MESSAGE Missing required bundle org.eclipse.jdt.core_0.0.0.
    !SUBENTRY 2 org.eclipse.jdt.launching.macosx 2 0 2013-04-23 18:06:27.286
    !MESSAGE Missing required bundle org.eclipse.jdt.launching_0.0.0.
    !SUBENTRY 2 org.eclipse.jdt.launching.macosx 2 0 2013-04-23 18:06:27.287
    !MESSAGE Missing required bundle org.eclipse.debug.core_0.0.0.
    !SUBENTRY 2 org.eclipse.jdt.launching.macosx 2 0 2013-04-23 18:06:27.287
    !MESSAGE Missing required bundle org.eclipse.core.resources_0.0.0.
    !SUBENTRY 1 org.eclipse.osgi 2 0 2013-04-23 18:06:27.287
    !MESSAGE Bundle reference:file:/E:/junorcp/target_win/plugins/org.eclipse.core.filesystem.win32.x86_1.1.0.v20080604-1400.jar was not resolved.
    !SUBENTRY 2 org.eclipse.core.filesystem.win32.x86 2 0 2013-04-23 18:06:27.287
    !MESSAGE Missing host org.eclipse.core.filesystem_[1.1.0,2.0.0).
    !SUBENTRY 1 org.eclipse.osgi 2 0 2013-04-23 18:06:27.287
    !MESSAGE Bundle reference:file:/E:/junorcp/target_win/plugins/org.eclipse.core.filesystem.hpux.ia64_32_1.0.0.v20080604-1400.jar was not resolved.
    !SUBENTRY 2 org.eclipse.core.filesystem.hpux.ia64_32 2 0 2013-04-23 18:06:27.287
    !MESSAGE Missing host org.eclipse.core.filesystem_[1.0.0,2.0.0).
    !SUBENTRY 1 org.eclipse.osgi 2 0 2013-04-23 18:06:27.287
    !MESSAGE Bundle reference:file:/E:/junorcp/target_win/plugins/org.eclipse.core.filesystem.linux.x86_64_1.0.100.v20080604-1400.jar was not resolved.
    !SUBENTRY 2 org.eclipse.core.filesystem.linux.x86_64 2 0 2013-04-23 18:06:27.287
    !MESSAGE Missing host org.eclipse.core.filesystem_[1.1.0,2.0.0).
    !SUBENTRY 1 org.eclipse.osgi 2 0 2013-04-23 18:06:27.287
    !MESSAGE Bundle reference:file:/E:/junorcp/target_win/plugins/org.eclipse.core.filesystem.linux.ppc_1.0.100.v20080604-1400.jar was not resolved.
    !SUBENTRY 2 org.eclipse.core.filesystem.linux.ppc 2 0 2013-04-23 18:06:27.288
    !MESSAGE Missing host org.eclipse.core.filesystem_[1.1.0,2.0.0).
    !SUBENTRY 1 org.eclipse.osgi 2 0 2013-04-23 18:06:27.288
    !MESSAGE Bundle reference:file:/E:/junorcp/target_win/plugins/org.eclipse.core.resources.win32.x86_3.4.0.v20071204.jar was not resolved.
    !SUBENTRY 2 org.eclipse.core.resources.win32.x86 2 0 2013-04-23 18:06:27.288
    !MESSAGE Missing host org.eclipse.core.resources_[3.4.0,3.5.0).
    !SUBENTRY 1 org.eclipse.osgi 2 0 2013-04-23 18:06:27.288
    !MESSAGE Bundle reference:file:/E:/junorcp/target_win/plugins/org.eclipse.core.filesystem.macosx_1.0.0.v20080604-1400.jar was not resolved.
    !SUBENTRY 2 org.eclipse.core.filesystem.macosx 2 0 2013-04-23 18:06:27.288
    !MESSAGE Missing host org.eclipse.core.filesystem_[1.0.0,2.0.0).

     
  • solocheng

    solocheng - 2013-04-24

    help!

     
  • Benjamin Pasero

    Benjamin Pasero - 2013-04-24

    I have attached how the dependencies should look like there, do you have the same?

     
    Attachments
    • solocheng

      solocheng - 2013-04-25

      this is my plug-ins dependencies ,i do not have the check box named "workspace" in your attachment picture. so workspace checkbox is necessary? where can i set it?

       
      Last edit: solocheng 2013-04-25
  • Benjamin Pasero

    Benjamin Pasero - 2013-04-25

    yes you need them! I am sure you did not carefully enough follow the steps of the wiki. maybe you did not import the RSSOwl project folder properly? how does your package explorer look like?

     
    • solocheng

      solocheng - 2013-04-25

      okay,actuall,i download the source code package from here:https://github.com/bpasero/rssowl-target/archive/master.zip and unzip it .I import a exist projects into eclispe workspace from the unzip folder.as you mentioned above ,i found that my project was not a plug-in project but a common eclipse projet,it's so weird! is that source code download url is wrong?can u tell me the correct download path?
      BTW my package is here:

       
      Last edit: solocheng 2013-04-25
      Attachments
  • Benjamin Pasero

    Benjamin Pasero - 2013-04-25

    Ah you have not imported correctly then. The projects must all be top level and not subprojects of that folder. I have https://github.com/bpasero/rssowl-target/blob/master/README.md#import-rssowl-sources to clarify this.

     
    • solocheng

      solocheng - 2013-04-26

      Ah,I just skim reading your guide!I have built successfully!thx!!!!
      BTW:why do't u put the all subprojects into one project?

       
    • solocheng

      solocheng - 2013-04-26

      hi Pasero

      Because i am a new guy for RCP development, can u tell me the name of swt desginer tool that u used for developing rsswol,thx again!!

       
  • Benjamin Pasero

    Benjamin Pasero - 2013-04-26

    it is not possible to nest projects in eclipse. the UI is written by hand, no tool involved.

     
  • solocheng

    solocheng - 2013-04-26

    okay,i got it!thx!

     
    • Waquesseix

      Waquesseix - 2013-06-06

      Did you success building RSSOwl? I tried that for supporting feedly API, but I couldn't build.

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks